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1. Η εφαρμογή Pajek 
 

Το Pajek1 είναι μια δωρεάν εφαρμογή για Windows η οποία αναπτύχθηκε από τους 

καθηγητές A. Mrvar και V. Batagelj2. Χρησιμοποιείται για την ανάλυση και οπτικοποί-

ηση δικτύων (στο εξής το δίκτυο θα αναφέρεται και ως δικτύωμα) που αποτελούνται 

από χιλιάδες ή και εκατομμύρια κορυφές (ή κόμβους, ή στοιχεία). Είναι γραμμένη σε 

Delphi και η ανάπτυξή της ξεκίνησε το 1996. Η λέξη «Pajek» είναι σλοβενική και ση-

μαίνει «αράχνη». 

 

Μερικά από τα δίκτυα που μπορούν να αναλυθούν και να οπτικοποιηθούν με το Pajek 

είναι: 

 

 Δίκτυα οργανικών μορίων στην οργανική χημεία 

 Αλληλεπιδράσεις δικτύων πρωτεϊνών – υποδοχέων 

 Κοινωνικά δίκτυα 

 Γενεαλογικά δέντρα 

 Δίκτυα Internet 

 Δίκτυα βιβλιογραφικών παραπομπών 

 Δίκτυα διάχυσης (ιών, ειδήσεων κ.α.) 

 Δίκτυα με κόμβους δύο ειδών (εξόρυξη δεδομένων από αυτά) 

 Και πολλά άλλα3 

 

Ο σχεδιασμός του Pajek βασίστηκε σε προηγούμενη εμπειρία ανάπτυξης λογισμικού 

των δημιουργών του4. Βασίστηκε σε βιβλιοθήκες αλγορίθμων που αφορούν γρά-

φους5 (Graph και X-Graph), σε λογισμικό ανάλυσης και οπτικοποίησης (STRAN, 

RelCalc, Draw, Energ), και στην γλώσσα σήμανσης περιγραφής γράφων NetML η ο-

ποία βασίζεται στη γλώσσα σήμανσης SGML (Standard Generalized Markup Lan-

guage). 

 

                                                             
1 http://vlado.fmf.uni-lj.si/pub/networks/pajek 
2 Πανεπιστήμιο Ljubljana, Σλοβενία (www.uni-lj.si) 
3 http://vlado.fmf.uni-lj.si/pub/networks/data 
4 http://vlado.fmf.uni-lj.si/pub/networks 
5 http://en.wikipedia.org/wiki/Graph_theory 
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Μια ειδική έκδοση του Pajek, είναι το Pajek–XXL6. Έχει σημαντικά λιγότερες απαιτή-

σεις σε μνήμη (2 έως 3 φορές) και είναι ταχύτερο σε περιπτώσεις διεργασιών με συ-

χνή χρήση μνήμης (π.χ. παραγωγή τυχαίων δικτύων, εξαγωγή δεδομένων δικτύων, 

συρρίκνωση δικτύων κ.α.). 

 

Η ανάπτυξη του Pajek έχει γίνει με βάση τους εξής στόχους: 

 

 Να υποστηρίζει απλοποίηση  μέσω της (αναδρομικής) αποσύνθεσης ενός με-

γάλου δικτύου σε πολλά μικρότερα δίκτυα τα οποία να μπορούν στη συνέχεια 

να υποστούν περαιτέρω επεξεργασία χρησιμοποιώντας πιο εξελιγμένες με-

θόδους. 

 Να παρέχει στο χρήστη ισχυρά εργαλεία οπτικοποίησης – παρουσίασης των 

δεδομένων του. 

 Να εφαρμόζει ένα σύνολο αποτελεσματικών αλγορίθμων για την ανάλυση 

μεγάλων δικτύων των οποίων ο χρόνος εκτέλεσης θα παρουσιάζει υποτετρα-

γωνική πολυπλοκότητα7. 

 

Με το Pajek  είναι  δυνατή: 

 

 Η εύρεση συστάδων (υποσύνολα, γειτονικές κορυφές που παρουσιάζουν κά-

ποιο νόημα, πυρήνες, κλπ.) σε ένα δίκτυο. 

 Η εξαγωγή κορυφών που ανήκουν σε ίδιες συστάδες και η παρουσίασή τους 

ξεχωριστά (λεπτομερής τοπική θέαση). 

 Η συμπύκνωση κορυφών σε συστάδες. 

 Η παρουσίαση των σχέσεων που υπάρχουν μεταξύ συστάδων (ευρεία σφαι-

ρική θέαση). 

 

Τέλος, εκτός από τα κανονικά δίκτυα (κατευθυνόμενα, μη-κατευθυνόμενα, μικτά), το 

Pajek υποστηρίζει επίσης: 

 

 Πολυσχεσιακά δίκτυα 

 Δίκτυα 2-mode (διμερείς γράφοι – δίκτυα μεταξύ δύο αποκομμένων συνόλων 

από κορυφές) 

 Προσωρινά δίκτυα (δυναμικοί γράφοι – δίκτυα που μεταβάλλονται με τον 

χρόνο) 

 

                                                             
6 http://mrvar.fdv.uni-lj.si/pajek 
7 http://en.wikipedia.org/wiki/Time_complexity#Sub-quadratic_time 
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2. Τύποι αντικείμενων 
 

Στο Pajek χρησιμοποιούνται έξι τύποι αντικειμένων: 

 

i. Δίκτυα (Networks). Είναι τα κύρια αντικείμενα (κορυφές και γραμμές). Η προ-

επιλεγμένη επέκτασή τους είναι .net 

ii. Κατατμήσεις (Partitions) – Δείχνουν σε ποια κλάση κορυφών ανήκει η κάθε 

κορυφή. Η επέκτασή τους είναι .clu 

iii. Διανύσματα (Vectors) – Περιλαμβάνουν τιμές για κάθε κορυφή. Επέκταση 
.vec 

iv. Μεταθέσεις (Permutations) – Αναδιατάξεις των κορυφών. Επέκταση .per 

v. Συστάδες (Clusters) – Υποσύνολα κορυφών. Επέκταση .cls 

vi. Ιεραρχίες (Hierarchies) – Ιεραρχικά ταξινομημένες κορυφές. Επέκταση .hie 

 

Στο κύριο παράθυρο του γραφικού περιβάλλοντος του Pajek περιλαμβάνονται ως 

πεδία εισόδου, και οι έξι αυτοί τύποι αντικειμένων που αναφέρθηκαν: 

 

 
 

Τη στιγμή που γράφονται αυτές οι γραμμές, η τελευταία έκδοση του Pajek είναι η 

4.03 (2 Απριλίου 2015) και διατίθεται σε 32 και 64bit εκδόσεις. 
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Μετά την εγκατάσταση του προγράμματος δημιουργείται το παρακάτω σύστημα αρ-

χείων: 

 

 
 

Διαδρομή εγκατάστασης: C:\Users\<UserName>\AppData\Local\Pajek 

 

 

3. Τα εργαλεία της εφαρμογής Pajek 
 

Το γραφικό περιβάλλον του Pajek δεν είναι ιδιαίτερα φιλικό προς τον χρήστη. Δια-

φέρει πολύ από τα περιβάλλοντα που έχουμε συνηθίσει στις περισσότερες εφαρμο-

γές, όπου ο τρόπος λειτουργίας τους είναι προφανής σχεδόν από την πρώτη ματιά.  

 

Παρ’ όλα αυτά, παρατηρώντας το υπό την κατάλληλη οπτική γωνία, και έχοντας το 

απαραίτητο θεωρητικό υπόβαθρο, γρήγορα καταλαβαίνει κανείς τις αξιόλογες δυνα-

τότητές του. Το Pajek λειτουργεί ουσιαστικά σαν ένα επιστημονικό κομπιουτεράκι 

που είναι εξειδικευμένο για πράξεις επάνω σε δίκτυα. 
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3.1 Το κεντρικό παράθυρο εργασίας 

 

Το κεντρικό παράθυρο της εφαρμογής αποτελείται από δύο περιοχές. Την περιοχή 

του κυρίως μενού (Κόκκινη – Α) και την περιοχή των δεδομένων (Κίτρινη Β):  

 

 
 

Πιο κάτω γίνεται μια πολύ σύντομη αναφορά στη λειτουργικότητα του κάθε στοι-

χείου που απαρτίζει το γραφικό περιβάλλον του Pajek. Μια λεπτομερής ανάλυση γί-

νεται στο εγχειρίδιο χρήσης του προγράμματος [1] το οποίο έχουν συντάξει οι ίδιοι 

οι δημιουργοί του. 

 

3.1.1 Η περιοχή δεδομένων 

 

Η περιοχή Β αποτελείται με τη σειρά της από έξι υποπεριοχές (όσες και οι τύποι αντι-

κειμένων που υποστηρίζει το Pajek) οι οποίες χαρακτηρίζονται από την ονομασία 

των έξι μεγάλων κουμπιών της: 

 

 Networks – Εδώ εισάγεται το αρχείο δικτύου (filename.net) που μελε-

τάται. 

 Partitions – Το αρχείο (filename.clu) με τα δεδομένα ταξινόμησης 

των κορυφών ενός δικτυώματος. Έχει τέτοια δομή ώστε κάθε κορυφή να α-

ντιστοιχείται σε μία και μόνο κλάση. 
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 Vectors – Το αρχείο (filename.vec) με τα δεδομένα στα οποία αποδί-

δονται αριθμητικές τιμές σε κάθε κορυφή του δικτύου. Πρόκειται για μια λί-

στα αριθμών όπου κάθε γραμμή (εγγραφή) αντιστοιχεί σε μία τιμή που 

συνδέεται με ένα κόμβο του δικτυώματος. 

 Permutations – Αρχείο (filename.per) στο οποίο μας επιτρέπεται η α-

ναδιοργάνωση των κόμβων σε διαφορετική σειρά (ακολουθία). 

 Cluster – Αρχείο (filename.cls) ομαδοποίησης κόμβων που έχουν κά-

ποιο ιδιαίτερο ενδιαφέρον για εμάς. 

 Hierarchy – Αρχείο (filename.hie) ταξινόμησης κορυφών για περι-

πτώσεις που μια κορυφή (ή ένα group κορυφών) ανήκει ταυτόχρονα σε πε-

ρισσότερες από μία κλάσεις. 

 

Η διαφορά ενός αρχείου με δεδομένα τύπου αντικειμένου “Partition”, με ένα αρχείο 

τύπου  “Hierarchy”, είναι ότι στο πρώτο μια κορυφή (ή ένα group κορυφών) δεν μπο-

ρεί να ανήκει ταυτόχρονα σε περισσότερες από μία κλάσεις. 

 

Οι πρώτες τρεις υποπεριοχές χρησιμοποιούνται σε όλα σχεδόν τα δίκτυα που αναλύ-

ονται, ενώ οι υπόλοιπες τρεις, μόνο σε περίπλοκα δίκτυα στα οποία υπάρχουν ανά-

γκες αναδιοργάνωσης, ομαδοποίησης και ιεράρχησης των κόμβων. 

 

Σε καθεμιά από τις έξι υποπεριοχές περιλαμβάνονται γραφικά στοιχεία ελέγχου για 

την επίτευξη της απαιτούμενης λειτουργικότητας κατά τον χειρισμό των δεδομένων: 

 

 
 

Το μεγάλο κουμπί επάνω αριστερά χρησιμεύει για την προσθήκη επιπλέον πεδίων 

εισαγωγής δικτύων. 

 

Τα τέσσερα μικρότερα κουμπιά με τα εικονίδια φακέλου, δισκέττας, μεγεθυντικού 

φακού και του λατινικού “i”, χρησιμεύουν για τις ενέργειες ανοίγματος αρχείου, απο-

θήκευσης αρχείου, εμφάνισης και επεξεργασίας ιδιοτήτων αντικειμένου – αρχείου, 

και πληροφοριών (info), αντίστοιχα. 

 

Τα πτυσσόμενα πεδία κειμένου (drop – down lists) περιλαμβάνουν τα ονόματα των 

αρχείων που μπορεί να υπάρχουν στις έξι υποπεριοχές. Αν για παράδειγμα εναποθέ-
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σουμε κάνοντας drag n’ drop ένα αρχείο δικτύου .net, τότε θα εμφανιστεί στο αντί-

στοιχο πεδίο, το όνομά του και η διαδρομή του στο σκληρό δίσκο (και ορισμένες επι-

πλέον πληροφορίες που θα δούμε στη συνέχεια). 

 

Το κουμπί με το εικονίδιο μολυβιού που υπάρχει μόνο δίπλα από την περιοχή Net-

works, είναι μια συντόμευση για την εντολή Draw > Network ή οποία απεικονίζει 

στον χρήστη το τρέχον δίκτυο. 

 

Tα κουτιά επιλογής (check boxes) χρησιμεύουν για την μορφοποίηση της εμφάνισης 

των αντικειμένων κατά την απεικόνισή τους, όταν υπάρχουν πολλαπλά όμοια αντι-

κείμενα (πχ: περισσότερα του ενός partitions ή/και vectors): 

 

 
 

Διατίθενται μόνο για την υποπεριοχή των Partitions και των Vectors μιας και 

μόνο εκεί υπάρχει νόημα διαφοροποίησης της εμφάνισής τους κατά την απεικόνιση. 

Για παράδειγμα, κατά την απεικόνιση ενός δικτύου χωρών, θα ήταν πρακτικό να εμ-

φανίζονται διαφορετικά αυτές που ανήκουν σε διαφορετική ήπειρο από τις υπόλοι-

πες. 

 

3.1.2 Η περιοχή του κυρίως μενού 

 

Το κεντρικό μενού σχετίζεται άμεσα με τις έξι υποπεριοχές (και δη, τύπους αντικει-

μένων) της περιοχής δεδομένων. 

 

Τα παρακάτω μενού λειτουργούν ως βοηθητικά εργαλεία για τη διαχείριση αρχείων, 

την αποθήκευση ρυθμίσεων, την γραφική απεικόνιση δεδομένων κ.α. τα οποία θα α-

ναφερθούν στις επόμενες παραγράφους: 

 

 File 

 Options 
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 Draw 

 Macro 

 Info 

 Tools 

 

Τα μενού που περιλαμβάνονται στη λίστα που ακολουθεί σχετίζονται με πράξεις και 

υπολογισμούς που αφορούν τους έξι τύπους αντικειμένων του Pajek: 

 

 Network και Networks 

 Operations 

 Partition και Partitions 

 Vector και Vectors 

 Permutation και Permutations 

 Cluster 

 Hierarchy 

 

Όσα από τα παραπάνω είναι στον πληθυντικό, απαιτούν την είσοδο δύο (η περισσο-

τέρων σε ορισμένες περιπτώσεις) αντικειμένων του ίδιου τύπου για να πραγματο-

ποιηθούν. Εξαίρεση αποτελεί το μενού “Operations” όπου απαιτούνται δύο είδη 

αντικειμένων διαφορετικού τύπου. 

 

3.1.2.1 Μενού File 

 

Βασικές λειτουργίες εισόδου – εξόδου με τους έξι τύπους αντικειμένων: 
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3.1.2.2 Μενού Network και Networks 

 

Το μενού “Network” αφορά λειτουργίες για τις οποίες μόνο ένα δίκτυο (ή τίποτα στην 

περίπτωση των τυχαίων δικτύων) είναι απαραίτητο ως είσοδο: 

 

 
 

Το μενού “Networks” αφορά λειτουργίες (πράξεις) που εφαρμόζονται σε δύο δίκτυα: 
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3.1.2.3 Μενού Operations 

 

Ως είσοδος απαιτείται ένα δίκτυο και ένας ακόμη τύπος αντικειμένου: 

 

 
 

3.1.2.4 Μενού Partition και Partitions 

 

Το μενού “Partition” περιλαμβάνει λειτουργίες για μία μόνο κατάτμηση του δικτύου: 
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Το μενού “Partitions” αφορά λειτουργίες που απαιτούν δύο κατατμήσεις: 

 

 
 

3.1.2.5 Μενού Vector και Vectors 

 

Το μενού “Vector” περιλαμβάνει λειτουργίες για ένα μόνο διάνυσμα του δικτύου: 
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Το μενού “Vectors” αφορά λειτουργίες για δύο διανύσματα. Τα διανύσματα αυτά θα 

πρέπει, είτε να είναι ίδιας διάστασης, είτε το ένα από τα δύο να βαθμωτό (scalar): 

 

 
 

3.1.2.6 Μενού Permutation και Permutations 

 

Το μενού “Permutation” περιλαμβάνει λειτουργίες για ένα μόνο σύνολο μεταθέσεων 

του δικτύου: 

 

 
 

Το μενού “Permutations” αφορά λειτουργίες για δύο σύνολα μεταθέσεων: 
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3.1.2.7 Μενού Cluster 

 

Δημιουργεί ή μετατρέπει μία συστάδα, σε κατάτμηση (make partition): 

 

 
 

3.1.2.8 Μενού Hierarchy 

 

Λαμβάνει ως είσοδο μια ιεραρχία και, είτε εξάγει από αυτή μια συστάδα, είτε την με-

τατρέπει σε δίκτυο, ή σε κατάτμηση, ή σε ένα σύνολο μεταθέσεων: 

 

 
 

3.1.2.9 Μενού Draw 

 

Σε αυτό το μενού περιλαμβάνονται όλες οι δυνατότητες απεικόνισης δεδομένων που 

υποστηρίζει το Pajek: 
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3.1.2.10 Μενού Macro 

 

Μας δίνει τη δυνατότητα να δημιουργήσουμε μακροεντολές8: 

 

 
 

3.1.2.11 Μενού Tools 

 

Μας δίνει τη δυνατότητα εξαγωγής των δεδομένων μας σε διάφορες μορφές προκει-

μένου να είναι δυνατή η εισαγωγή τους σε λογισμικό τρίτων και έτσι να μπορεί να 

επιτευχθεί η περεταίρω επεξεργασία τους (πχ: στατιστική ανάλυση μέσω SPSS9): 

 

 
 

 

 

 

 

                                                             
8 https://en.wikipedia.org/wiki/Macro_(computer_science) 
9 https://en.wikipedia.org/wiki/SPSS 
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4. Δημιουργία αρχείων δικτύου για το Pajek 
 

Υπάρχουν αρκετοί τρόποι για την δημιουργία αρχείων δεδομένων που θα μπορούν 

να διαβαστούν από το Pajek. Οι τρεις κυριότεροι είναι: 

 

i. Μέσω του Pajek 

ii. Με επεξεργαστή κειμένου (πχ: notepad) 

iii. Μέσω του Matlab 

iv. Μέσω της γλώσσας προγραμματισμού Python 

v. Μέσω της εφαρμογής Excel2Pajek.exe 

vi. Μέσω της εφαρμογής TXT2Pajek.exe 

vii. Δημιουργώντας σχεσιακή βάση δεδομένων (πχ: μέσω Microsoft Access) 

 

4.1 Μέσω του Pajek 

 

Η δημιουργία ενός δικτύου μέσω του Pajek ή μέσω οποιασδήποτε άλλης μεθόδου 

από τις τρεις που αναφέρθηκαν στην προηγούμενη παράγραφο, έχει νόημα όταν οι 

ίδιοι έχουμε συλλέξει τα δεδομένα που επιθυμούμε να αναλύσουμε. Επίσης αποτελεί 

και ένα πολύ καλό τρόπο εκμάθησης του Pajek. 

 

Αρχικά δημιουργούμε ένα τυχαίο δίκτυο επιλέγοντας από το κεντρικό μενού του Pa-

jek: Network > Create Random Network > Total No. of Arcs. Στο 

παράθυρο διαλόγου που εμφανίζεται, θέτουμε έναν αριθμό κορυφών (Number of 

Vertices = 28) και έναν αριθμό γραμμών (Number of Arcs = 0) που θα 

ενώνουν τις κορυφές αυτές: 
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Επιλέγοντας OK, δημιουργείται ένα νέο δίκτυο και προστίθεται στην πτυσσόμενη λί-

στα διαθέσιμων δικτύων του κεντρικού παραθύρου του Pajek: 

 

 
 

Για να δούμε το δίκτυο που δημιουργήθηκε επιλέγουμε Draw > Network:  
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Κατά τη δημιουργία του δικτύου ουσιαστικά παρήχθη ένας ασύνδετος γράφος αφού 

θέσαμε τον αριθμό των γραμμών να είναι ίσος με το μηδέν. Προκειμένου να προσθέ-

σουμε συνδέσεις στο δίκτυό μας θα πρέπει να επεξεργαστούμε το δίκτυο που δη-

μιουργήθηκε. Αυτό γίνεται, είτε επιλέγοντας: File > Network > View/Edit, 

είτε με κλικ στο κουμπί με το εικονίδιο του μεγεθυντικού φακού, που υπάρχει κάτω 

από το κουμπί “Networks”. Στο παράθυρο διαλόγου που θα ανοίξει, πληκτρολο-

γούμε, είτε τον αριθμό της κορυφής την οποία θέλουμε να ενώσουμε (vertex 

number), είτε την ετικέτα της (vertex label, πχ: v7): 

 

 
 

Επιλέγοντας OK, εμφανίζεται ένα νέο παράθυρο διαλόγου για τον σχεδιασμό της 

νέας γραμμής (Newline): 

 

 
 

Με διπλό κλικ στο Newline μας δίνεται η δυνατότητα να εισάγουμε τον τρόπο με 

τον οποίο θα σχεδιαστεί η νέα γραμμή: 
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Οι επιλογές σχεδίασης γραμμής που μας δίνονται είναι: 

 

 Από την κορυφή που ενώνουμε, προς τη v7: Into vertex (+) 

 Από την v7, προς την κορυφή που ενώνουμε: Out of vertex (-) 

 Ένωση της v7 με κάποια άλλη, χωρίς κατεύθυνση: Edge (nosign) 

 

Το αποτέλεσμα της εντολής +23 επομένως, θα είναι μία γραμμή η οποία έχει φορά 

από την κορυφή 23 προς την κουφή αναφοράς μας που σε αυτή την περίπτωση είναι 

η 7: 

 

 
 

Προσθέτοντας άλλες δύο συνδέσεις – γραμμές με τους άλλους δύο τρόπους σχεδία-

σης (Newline, -15 και 19), το δίκτυό μας γίνεται: 
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Το παράθυρο διαλόγου επεξεργασίας δικτύου, σε αυτό το σημείο έχει ενημερωθεί με 

τις νέες συνδέσεις: 

 

 
 

Με τον ίδιο τρόπο μπορούμε να συνεχίσουμε να δημιουργούμε συνδέσεις προκειμέ-

νου να ολοκληρώσουμε το δίκτυο που ενδιαφέρει κάθε φορά. 
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Εξ’ ορισμού, όλες οι γραμμές έχουν βαθμό συσχέτισης 1 και τιμή (val) 1.00000, 

όπως φαίνεται και στην προηγούμενη εικόνα. Μπορούμε να αλλάξουμε αυτές τις τι-

μές με δεξί κλικ σε όποια μας ενδιαφέρει: 

 

 
 

Σε αυτό το σημείο μπορούμε να αποθηκεύσουμε το δίκτυό μας σε αρχείο με επέκταση 

.net καθώς το Pajek δεν κάνει αυτόματη αποθήκευση: 
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Μετά την επιτυχή αποθήκευση, μας επιστρέφεται από το Pajek μια σύντομη αναφορά 

για τις λεπτομέρειες αποθήκευσης: 

 

 
 

Τα περιεχόμενα του αρχείου mynetwork.net παρατίθενται ως παράρτημα. 

 

4.2 Μέσω του Matlab 

 

Το Matlab αποτελεί πανίσχυρο εργαλείο για την επιστημονική έρευνα. Έχει λοιπόν 

νόημα να μπορεί να επικοινωνεί με άλλα λογισμικά εισάγοντας ή εξάγοντας δεδο-

μένα σε κατάλληλη μορφή κάθε φορά. 

 

Σε αυτή την παράγραφο παρατίθεται ένα σενάριο δημιουργίας αρχείου .net, μέσω 

του Matlab, για το Pajek. 

 

Για το παράδειγμά μας θα γίνει χρήση των δύο παρακάτω αρχείων Matlab: 

 

 get_random_graph.m – Επιστρέφει ένα μη-κατευθυνόμενο, τυχαίο δί-

κτυο 20 κόμβων, με μέσο όρο 3 συνδέσεις ανά κόμβο (πιθανότητα 3/20 ή 

15%), σε μορφή .mat. 

 write_matrix_to_pajek.m – Μετατρέπει δεδομένα Matlab που βρί-

σκονται σε μορφή .mat, σε αρχείο δικτύου Pajek μορφής .net. 

 

Ο πηγαίος κώδικας των δύο αυτών αρχείων, παρατίθεται ως παράρτημα στο τέλος 

του εγγράφου. 

 

Ας υποθέσουμε ότι το παράδειγμά μας αφορά την νευροεπιστήμη. Έστω δηλαδή, ότι 

έχουμε ένα σύνολο εγκεφαλικών περιοχών R, μεγέθους N. Για κάθε ζεύγος περιοχών 

i και j (όπου i διάφορο του j), μπορεί να υπάρχει μια νευρωνική σύνδεση ισχύος  S(i,j). 

Επίσης, ας υποθέσουμε ότι δεν γνωρίζουμε την κατευθυντικότητα αυτής της σύνδε-

σης, πράγμα που σημαίνει ότι S(i,j) == S(j,i). Άρα ο πίνακας γειτνίασης είναι συμμετρι-

κός. Αυτό το εγκεφαλικό δίκτυο, μπορεί να περιγραφεί από ένα πίνακα γειτνίασης 
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AM ο οποίος θα είναι ένας τετραγωνικός (και συμμετρικός) MxN πίνακας. Κάθε στοι-

χείο του πίνακα αυτού περιλαμβάνει μία τιμή η οποία αναπαριστά την ισχύ συνδέ-

σεως μεταξύ των εγκεφαλικών περιοχών i και j. Σε ορολογία δικτύων, ο πίνακας AM 

αναπαριστά ένα μη-κατευθυνόμενο δίκτυο με βάρη, μεγέθους N. 

 

Αρχικά εκτελούμε στη γραμμή εντολών του Matlab τη συνάρτηση δημιουργίας τυ-

χαίου δικτύου get_random_graph() περνώντας τις επιθυμητές παραμέτρους ως 

εξής: 

 
>> ΑΜ = get_random_graph(20,3) 

 

Το αποτέλεσμα είναι όντως ένα τυχαίο δίκτυο: 

 

 
 

Τα περιεχόμενά του είναι όμως μηδενικά και άσσοι. Επειδή θέλουμε το δίκτυό μας να 

είναι κατευθυνόμενο, εκτελούμε ένα επιπλέον βήμα: 

 
>> AM = AM.*rand(20); 

 

Μετά όμως από αυτό το βήμα, ο πίνακας AM δεν είναι συμμετρικός. Για να είμαστε 

ακριβείς θα έπρεπε να καθρεπτίσουμε το άνω τρίγωνό (δηλαδή, τα στοιχεία πάνω 

από την κύρια διαγώνιο) του στο κάτω. Καθώς όμως η συνάρτηση δημιουργίας του 

αρχείου .net θα χρησιμοποιήσει μόνο τα στοιχεία επάνω από την κύρια διαγώνιο 

(λόγω του ότι η παράμετρος directed έχει την τιμή false), δεν χρειάζεται να προχω-

ρήσουμε σε αυτή την ενέργεια. 

 

Για να αναπαραστήσουμε το δίκτυό μας σε τρισδιάστατη μορφή (όπως είναι διατε-

ταγμένοι και οι πραγματικοί νευρώνες του εγκεφάλου), θα πρέπει να καθορίσουμε 
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συντεταγμένες για την κάθε κορυφή του δικτύου. Μόνο που και σε αυτή την περί-

πτωση, οι συντεταγμένες θα είναι τυχαίες αφού θα δημιουργηθούν μέσω της εκτέλε-

σης της παρακάτω εντολής: 

 
>> coordinates = rand(20,3) 

 

Και το αποτέλεσμα είναι: 

 
coordinates = 

 

    0.5312    0.7067    0.3508 

    0.1088    0.5578    0.6855 

    0.6318    0.3134    0.2941 

    0.1265    0.1662    0.5306 

    0.1343    0.6225    0.8324 

    0.0986    0.9879    0.5975 

    0.1420    0.1704    0.3353 

    0.1683    0.2578    0.2992 

    0.1962    0.3968    0.4526 

    0.3175    0.0740    0.4226 

    0.3164    0.6841    0.3596 

    0.2176    0.4024    0.5583 

    0.2510    0.9828    0.7425 

    0.8929    0.4022    0.4243 

    0.7032    0.6207    0.4294 

    0.5557    0.1544    0.1249 

    0.1844    0.3813    0.0244 

    0.2120    0.1611    0.2902 

    0.0773    0.7581    0.3175 

    0.9138    0.8711    0.6537 

 

Σε αυτό το σημείο θα μπορούσαμε να δώσουμε ονόματα στις κορυφές του δικτύου 

δημιουργώντας ένα vector με strings (τα ονόματα των περιοχών του εγκεφάλου). Ό-

μως, απουσία αυτού του vector, η συνάρτηση θα χρησιμοποιήσει τους δείκτες των 

περιοχών (1 έως N) σαν ετικέτες (labels), κάτι που για τις ανάγκες αυτού του παρα-

δείγματος είναι αρκετό. 

 

Αφού πλέον έχουμε καθορίσει το δίκτυό μας, μπορούμε να το εξάγουμε σε μορφή 

.net για το Pajek, με την εξής εντολή: 

 

write_matrix_to_pajek(AM,'random.net','weighted',true,'directed',false, 

                                                                                                      'coords',coordinates); 
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Το αρχείο random.net έχει δημιουργηθεί στον τρέχοντα κατάλογο εργασίας του 

Matlab (Τα περιεχόμενά του παρατίθενται σε αντίστοιχο παράρτημα στο τέλος του 

εγγράφου), και μπορεί να εισαχθεί στο Pajek. Επιλέγοντας στη συνέχεια, Draw > Net-

work, εμφανίζεται το δίκτυό μας:  

 

 
 

Εφόσον είναι τρισδιάστατο, μπορούμε να το περιστρέψουμε χρησιμοποιώντας τα 

πλήκτρα x, y, z, του πληκτρολογίου. 

 

4.3 Μέσω της γλώσσας προγραμματισμού Python 

 

Η γλώσσα προγραμματισμού Python10 είναι πλέον η δεύτερη δημοφιλέστερη μετά 

την Java. Ειδικά στην ακαδημαϊκή κοινότητα, πολλές φορές έρχεται πρώτη, ενώ σε 

αρκετές περιπτώσεις αντικαθιστά ακόμα και το λογισμικό Matlab. Για το λόγο αυτό 

υπάρχει τεράστια εγκατεστημένη βάση προγραμματιστών που αναπτύσσουν και ε-

πεκτείνουν τη λειτουργικότητά της. Η ανάπτυξη βιβλιοθηκών είναι ίσως ο κυριότε-

ρος τρόπος επέκτασής της Python. 

 

                                                             
10 http://en.wikipedia.org/wiki/Python_(programming_language) 
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Όσον αφορά την υποστήριξη της Python για επεξεργασία γράφων και δικτύων, υ-

πάρχουν δύο βιβλιοθήκες οι οποίες αναφέρονται συχνότερα στο Διαδίκτυο: Η βιβλιο-

θήκη NetworkX11 και η βιβλιοθήκη iGraph12. Και οι δύο βιβλιοθήκες διαθέτουν 

υποστήριξη για το Pajek. 

 

Συγκεκριμένα, η υλοποίηση13 της βιβλιοθήκης NetworkX για το Pajek, υποστηρίζει 

κατευθυνόμενους και μη-κατευθυνόμενους γράφους, συμπεριλαμβανομένων εκεί-

νων με κόμβους που με βρόχους προς τον εαυτό τους, αλλά και εκείνων με παράλλη-

λες ακμές. Στον παρακάτω πίνακα παρουσιάζονται οι τρεις συναρτήσεις της 

βιβλιοθήκης για ανάγνωση, εγγραφή και σάρωση γράφων Pajek: 

 

 
 

Η βιβλιοθήκη iGraph έχει και αυτή παρόμοιες δυνατότητες με την NetworkX, αλλά 

παρουσιάζει περισσότερες δυσκολίες κατά την εγκατάστασή της. Σε αντίθεση με την 

δεύτερη, δεν μπορεί να εγκατασταθεί από τη γραμμή εντολών της Python μέσω της 

εντολής pip install. 

 

4.4 Με επεξεργαστή κειμένου 

 

Η χρήση ενός επεξεργαστή κειμένου για τη δημιουργία ενός γράφου (ή δικτύου) από 

το πληκτρολόγιο, μπορεί να έχει, σχεδόν αποκλειστικά, εκπαιδευτικό σκοπό. Ακόμα 

και αν πρόκειται για την ανάγκη εισαγωγής πρωτογενών δεδομένων, αυτά συνήθως 

θα λαμβάνονται και στη συνέχεια θα μορφοποιούνται με εργαλεία που έχουν σχεδια-

στεί ειδικά για το σκοπό αυτό. 

 

Παρ’ όλα αυτά, είναι αρκετά χρήσιμο να γνωρίζει κανείς τη δομή ενός αρχείου .net 

αν πρόκειται να χρησιμοποιήσει ως βασικό του εργαλείο το Pajek. Για παράδειγμα, η 

ανάπτυξη των βιβλιοθηκών python που αναφέρθηκαν στην προηγούμενη παρά-

γραφο, έγινε εφικτή με προαπαιτούμενη αυτή τη γνώση.  

 

 

                                                             
11 http://networkx.github.io/documentation/development/reference/readwrite.pajek.html 
12 http://igraph.org/python/doc/tutorial/tutorial.html#igraph-and-the-outside-world 
13 www.networkx.github.io/documentation/development/_modules/networkx/readwrite/pajek.html 
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Ας δούμε ένα παράδειγμα μίας πολύ απλής μορφής αρχείου .net: 

 

 
 

Η γραφική του απεικόνιση (Draw>Network) φαίνεται στην επόμενη εικόνα: 

 

 
 

Στην εικόνα αυτή διακρίνουμε 7 κορυφές (Vertices), 3 τόξα (Arcs) και 2 ακμές 

(Edges). Στο αντίστοιχο αρχείο .net, κάτω από τις αγγλικές μεταφράσεις των 

τριών αυτών στοιχείων, περιλαμβάνονται γραμμές κειμένου στις οποίες καθορίζο-

νται ορισμένες από τις λεπτομέρειες σύνδεσης των κορυφών. 
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Πιο συγκεκριμένα, η πρώτη γραμμή (*Vertices 7) ακολουθείται από επτά γραμ-

μές οι οποίες περιλαμβάνουν τις επτά κορυφές του δικτύου. Καθεμιά από αυτές τις 

γραμμές περιλαμβάνει αντίστοιχα, τον αριθμό της κορυφής (1 έως 7), το σύμβολό της 

(v1 έως v7), και τρείς τιμές που αντιπροσωπεύουν τις συντεταγμένες της στο χώρο 

(x, y, z). Δεν επιτρέπονται κενές γραμμές και tabs. 

 

Κάτω από την γραμμή με την επικεφαλίδα *Arcs, υπάρχουν τρεις γραμμές που α-

φορούν τα τόξα κατευθυνόμενων συνδέσεων. Ο πρώτος αριθμός αφορά την κορυφή 

από την οποία ξεκινά το βέλος  και ο δεύτερος, την κορυφή στην οποία δείχνει. Ο 

τρίτος επηρεάζει το στυλ της γραμμής. Για παράδειγμα αν έχει αρνητικό πρόσημο 

σχεδιάζεται διακεκομμένη. 

 

Τέλος, οι μη-κατευθυνόμενες συνδέσεις περιγράφονται κάτω από τον τίτλο 

*Edges. 

 

Ένας δεύτερος τρόπος σύνταξης του αρχείου .net είναι για τις συνδέσεις των κορυ-

φών να χρησιμοποιηθεί πίνακας. Έτσι, η δομή του προηγούμενου δικτύου θα μπο-

ρούσε να συνταχθεί ως εξής: 

 

 
 

Ο πίνακας θα πρέπει να είναι τετραγωνικός και το μέγεθός του να συμφωνεί με τον 

αριθμό των κορυφών, διαφορετικά το Pajek πέφτει σε σφάλμα. 

 

Ο συγκεκριμένος τρόπος σύνταξης όμως έχει ένα προφανές μειονέκτημα. Το Pajek 

δεν είναι σε θέση να ξεχωρίσει της κατευθυνόμενες από τις μη-κατευθυνόμενες συν-
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δέσεις. Επομένως καλό θα είναι να αποφεύγεται για την περιγραφή σύνθετων δι-

κτύων με αμφίδρομες συνδέσεις μεταξύ των κορυφών.  Μπορεί να γίνει μετατροπή 

των κατευθυνόμενων σε μη, με την εντολή Network > Create New Network 

> Transform > Arcs to Edges > Bidirectional only. 

 

Όλα τα παραπάνω φυσικά, αφορούν δίκτυα one-mode όπου όλοι οι κόμβοι (κορυ-

φές) είναι ίδιου τύπου (πχ: πόλεις). Στα δίκτυα 2-mode που υπάρχουν δύο διαφορε-

τικοί σύνολα κόμβων, το αρχείο .net συντάσσεται ελαφρώς διαφορετικά. Οπότε αν 

υποθέσουμε ότι έχουμε 5 υπαλλήλους οι οποίοι εργάζονται σε 2 διαφορετικές εται-

ρείες, το αρχείο .net θα μπορούσε να είναι το ακόλουθο: 

 

 
 

Σε αυτή την περίπτωση ο δεύτερος αριθμός στην επικεφαλίδα *Vertices μπαίνει για 

να συμβολίσει το two-mode δίκτυο. 

 

Μέχρι στιγμής αναφέρθηκαν μόνο τα πιο βασικά δομικά στοιχεία τα οποία είναι απα-

ραίτητα για να καθορίσουν τη δομή ενός δικτύου. Το Pajek, επιτρέπει επιπλέον μορ-

φοποίηση και καθορισμό των χαρακτηριστικών των στοιχείων που ανήκουν στο 

δίκτυο (συντεταγμένες των κορυφών στο χώρο, σχήμα και χρώμα των κορυφών και 

των γραμμών). Για παράδειγμα, το παρακάτω αρχείο δικτύου: 
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Έχει ως αποτέλεσμα: 

 

 
 

Παρατηρούμε ότι ενώ στο αρχείο περιγράφουμε 4 κορυφές, στο δίκτυο που σχεδιά-

στηκε υπάρχουν 5. Αυτό θα μπορούσε να συμβεί ακόμα και αν δεν περιγράφαμε κα-

μία κορυφή αλλά αφήναμε μόνο την γραμμή *Vertices 5 την οποία το Pajek 

αυτόματα τη μεταφράζει και τη σχεδιάζει ως ένα δίκτυο 5 κορυφών με τις προεπι-

λεγμένες από το πρόγραμμα ρυθμίσεις τους. Γι’ αυτό και στην Πέμπτη κορυφή επε-

λέγησαν αυτόματα οι συντεταγμένες και το σχήμα της. 

 

4.5 Δημιουργώντας σχεσιακή βάση δεδομένων 

 

Τα δεδομένα των πολύ μεγάλων δικτύων είναι δυνατό να αποθηκεύονται σε σχεσια-

κές βάσεις δεδομένων. Σε μια τέτοια βάση, δύο πίνακες (tables) μπορούν να αντιπρο-

σωπεύσουν ένα δίκτυο one-mode. Ο ένας μπορεί να περιλαμβάνει τις κορυφές του 

δικτύου και ο άλλος τις γραμμές (συνδέσεις) μεταξύ των κορυφών αυτών. 

 

Ως παράδειγμα μπορούν να χρησιμοποιηθούν δεδομένα14 που αφορούν τις εισαγω-

γές μετάλλου σε όλο τον κόσμο (Βλέπε παράγραφο: «Σενάριο χρήσης με πραγματικά 

δεδομένα»): 

 

                                                             
14 http://vlado.fmf.uni-lj.si/pub/networks/data/esna/metalWT.htm 
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Ο πίνακας Countries περιλαμβάνει εγγραφές για όλες τις χώρες που συμμετέχουν 

και αποτελεί τον πυρήνα όλης της βάσης: 
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Ο πίνακας Imports περιλαμβάνει τις πληροφορίες σύνδεσης μεταξύ των χωρών και 

τα βάρη των συνδέσεων αυτών: 

 

 
 

Ο πίνακας Manufactures περιλαμβάνει εγγραφές για τις μη-κατευθυνόμενες συν-

δέσεις (edges) του δικτύου: 
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Ο πίνακας Neighbor, παίζει το ρόλο του πίνακα γειτνίασης: 

 

 
 

Μέσω της φόρμας Imports: Cereals, γίνεται η εισαγωγή των πρωτογενών δε-

δομένων. 

 

Τα υπόλοιπα, είναι ερωτήματα προς τη βάση δεδομένων. Ένα από αυτά είναι και το 

Export network to Pajek: arcs and edges. Μέσω αυτού του ερωτή-

ματος (με δεξί κλικ), καταφέρνουμε τελικά να εξάγουμε τα δεδομένα μας σε μορφή 

αρχείου που θα μπορεί στη συνέχεια να εισαχθεί στο Pajek: 
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4.6 Μέσω άλλων τύπων αρχείων 

 

Ένας άλλος τρόπος δημιουργίας δικτύου με το Pajek, είναι πρώτα αυτό να εξαχθεί 

από κάποια άλλη εφαρμογή, σε κάποιο αποδεκτό format, και στη συνέχεια να γίνει η 

εισαγωγή του μέσω του Pajek. Οι τύποι που υποστηρίζονται είναι: 

 

 UCINET DL15 (gephi) 

 Vega16 (Tomaz Pisanski project) 

 GEDCOM17 (Genealogical Data Communication) 

 BS (Ball and Stick) 

 MAC (Mac Molecule) 

 MOL18 (MDL MOLfile) 

 

 

5. Καθορισμός διάταξης δικτύου 
 

Η κεντρική ιδέα ενός δικτύου συνήθως λαμβάνεται από τον άνθρωπο μέσω της απει-

κόνισής της διάταξής του. Στο Pajek περιλαμβάνονται αρκετές αυτόματες και χειρο-

κίνητες ρουτίνες σχεδίασης. 

 

5.1 Αυτόματες ρουτίνες σχεδίασης 

 

Οι αυτόματες ρουτίνες διάταξης του Pajek είναι: 

 

 Ενέργειας 

 Pivot MDS19 

 VOS Mapping20 

 

Για την εφαρμογή ενός εκ των τριών, αφού έχουμε σχεδιάσει το δίκτυο μέσω του Pa-

jek (Draw/Network), επιλέγουμε Layout: 

 

                                                             
15 http://gephi.github.io/users/supported-graph-formats/ucinet-dl-format 
16 https://www.google.gr/search?q=Tomaz+Pisanski+Vega+project 
17 http://en.wikipedia.org/wiki/GEDCOM 
18 http://en.wikipedia.org/wiki/Chemical_table_file#Molfile 
19 http://mrvar.fdv.uni-lj.si/pajek/community/DrawPivotMDS.htm 
20 http://mrvar.fdv.uni-lj.si/pajek/community/DrawEnergy.htm 
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Μέσω των ρουτινών ενέργειας, το δίκτυο παρουσιάζεται ως ένα φυσικό σύστημα (πχ: 

μια πρωτεΐνη) του οποίου ψάχνουμε την βέλτιστη (ελάχιστη) ενεργειακή κατάσταση. 

Υπάρχουν δύο αλγόριθμοι: 

 

 Kamada – Kawai [2]. Σχεδίαση σε ένα επίπεδο. 

 Fruchterman – Reingold [3]. Σχεδίαση 2D ή 3D. 

 

Οι ρουτίνες Pivot MDS και VOS Mapping εφαρμόζονται σε πολύ μεγάλα δίκτυα, των 

εκατό χιλιάδων κορυφών (Pivot MDS) και άνω (VOS Mapping). Η ύπαρξη συμμετριών 

στο δίκτυο, βελτιώνει το αποτέλεσμα της απεικόνισής του, όταν γίνεται χρήση των 

ρουτινών αυτών. 

 

5.2 Χειροκίνητη σχεδίαση 

 

Η χειροκίνητη σχεδίαση, μπορεί να λειτουργεί συμπληρωματικά της αυτόματης όταν 

κρίνονται χρήσιμες ορισμένες διορθώσεις οι οποίες βελτιώνουν την τελική απεικό-

νιση του δικτύου. Μπορεί όμως να χρησιμοποιηθεί και μόνο αυτή, ιδιαίτερα όταν 

πρόκειται για πολύ απλά δίκτυα. 

 

Μπορούμε με το ποντίκι να μετακινούμε την κάθε κορυφή κατά βούληση. Επίσης εί-

ναι δυνατό να περιστρέψουμε κάποια εικόνα με τη βοήθεια των πλήκτρων: x, X, 

y, Y, z, Z (κάθε γράμμα αφορά τον άξονα περιστροφής, ενώ τα κεφαλαία ή τα 

μικρά αφορούν θετική ή αρνητική διεύθυνση, αντίστοιχα). Μπορεί να επιλεγεί ο-

ποιοσδήποτε άξονας περιστροφής επιλέγοντας Spin > Normal. Στη συνέχεια, η περι-

στροφή γύρω από τον επιλεγμένο άξονα γίνεται με τα πλήκτρα S και s. 

 

Η εστίαση (zoom) σε συγκεκριμένο τμήμα του δικτύου, επιτυγχάνεται κρατώντας το 

πατημένο το δεξί κλικ και σχεδιάζοντας ένα παράθυρο που περιλαμβάνει το τμήμα 

αυτό. Η επαναφορά γίνεται επιλέγοντας Redraw. 
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6. Αποθήκευση δικτύου 
 

Η αποθήκευση του δικτύου γίνεται μέσω της εντολής File>Network>Save, σε 

κάποια από τις επιθυμητές μορφές τις οποίες υποστηρίζει το Pajek: 

 

 
 

 

7. Δημιουργώντας partitions, vectors 
 

7.1 Δημιουργία Partition 

 

Τα partitions χρησιμοποιούνται για να περιγράψουν ονομαστικές ιδιότητες των κο-

ρυφών του δικτύου (πχ: 1-άνδρας, 2-γυναίκα). Όπως έχει ήδη αναφερθεί, η επέ-

κταση ενός τέτοιου αρχείου έχει την επέκταση .clu (clustering). 

 

Αν για παράδειγμα έχουμε ένα δίκτυο πέντε κορυφών και θέλουμε να τοποθετή-

σουμε τις κορυφές 1 και 5 στο cluster 1, και όλες τις άλλες στο cluster 2, το αντίστοιχο 

partition θα περιγράφεται από το παρακάτω αρχείο κειμένου: 

 
*Vertices 

1 

2 

2 

2 

1 

 

Φυσικά, η δημιουργία ενός partition είναι εφικτή και μέσω του Pajek επιλέγοντας 

Partition>Create Constant Partition (constant = 0). 
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Η διάσταση του partition στο Pajek έχει προεπιλεγμένο μέγεθος ίσο με τον αριθμό 

των κορυφών του δικτύου που επιλέγεται. Με αυτό τον τρόπο τοποθετούμε όλες τις 

κορυφές στο cluster 0. Στη συνέχεια επιλέγουμε File>Partition>Edit και για 

κάθε μονάδα εισάγουμε τον αριθμό cluster στο οποίο ανήκει. 

 

Όταν προβάλουμε το δίκτυο μαζί με το πρώτο partition (Draw > Network + 

First Partition), τα διαφορετικά χρώματα των κορυφών θα χρησιμοποιηθούν 

για να δείξουν σε ποιο cluster ανήκει η κάθε κορυφή. 

 

Ένας δεύτερος τρόπος για τον καθορισμό ενός partition επιτυγχάνεται επιλέγοντας 

Draw>Network+Create Null Partition. Με αυτό τον τρόπο εκτελούνται 

τρεις ενέργειες: 

 

 Δημιουργείται νέο partition μεγέθους ίσου με τον αριθμό των κορυφών 

 Όλες οι κορυφές εντάσσονται στο cluster 0 

 Το δίκτυο απεικονίζεται χρησιμοποιώντας το null (κενό) partition (όλες οι κο-

ρυφές έχουν χρώμα κυανό) 

 

7.2 Δημιουργία Vector 

 

Τα Vectors (διανύσματα) χρησιμοποιούνται για να περιγράφουν τις αριθμητικές ιδιό-

τητες των κορυφών (πχ: centralities21). Η επέκτασή τους είναι .vec και ένα παρά-

δειγμα vector θα μπορούσε να είναι και το ακόλουθο: 

 
*Vertices 5 

0.67 

0.19 

0.567 

1.6789 

0.05 

 

H απεικόνιση ενός vector γίνεται επιλέγοντας Draw > Network + First Vec-

tor. Τα μεγέθη των κορυφών θα είναι ανάλογα με τις τιμές των διανυσμάτων. 

 

 

 

                                                             
21 http://en.wikipedia.org/wiki/Centrality 
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8. Το αρχείο .paj 
 

Το αρχείο .paj (αρχείο project για το Pajek), είναι ένας βολικός τρόπος αποθήκευ-

σης όλων των δεδομένων ενός δικτύου μαζί με τα δεδομένα που αφορούν partitions, 

vectors, permutations, clusters και hierarchies. Με τον τρόπο αυτό αποφεύγεται το 

χειροκίνητο άνοιγμα του κάθε διαφορετικού αρχείου κάθε φορά που ανοίγουμε το 

Pajek. 

 

Μπορεί να δημιουργηθεί επιλέγοντας File>Pajek Project File>Save. Μετά 

από αυτή την ενέργεια, όλα τα τρέχοντα αντικείμενα που έχουν φορτωθεί στο Pajek 

θα αποθηκευτούν στο αρχείο αυτό. 

 

Για το άνοιγμα αρχείου .paj επιλέγουμε File>Pajek Project File>Read. 

 

 

9. Μορφές αρχείων εξόδου του Pajek 
 

Οι απεικονίσεις των δικτύων που δημιουργούνται μέσω του Pajek μπορούν να εξα-

χθούν σε διάφορες μορφές αρχείων τα οποία στη συνέχεια θα μπορούν να εισαχθούν 

είτε ως εικόνες σε αρχεία κειμένου, είτε ως αρχεία δεδομένων σε ειδικούς viewers. 

 

Η αποθήκευση σε κάποιο συγκεκριμένο αρχείο εξόδου γίνεται, είτε σε δισδιάστατη 

μορφή επιλέγοντας Export>2D:  
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Είτε σε τρισδιάστατη επιλέγοντας Export>3D: 

 

 
 

 

10. Τοπικές και ευρείες προβολές δικτύου 
 

Μια τοπική (local) προβολή δημιουργείται επιλέγοντας ένα υποδίκτυο το οποίο εξά-

γεται από κάποιο σύμπλεγμα κορυφών (πχ: σε μια τάξη μαθητών, οι σχέσεις μεταξύ 

των αγοριών μόνο). 

 

Μια ευρεία ή οικουμενική (global) προβολή, επιτυγχάνεται μέσω της συρρίκνωσης 

κορυφών που βρίσκονται στο ίδιο σύμπλεγμα (cluster) σε μια νέα κορυφή. Με αυτό 

τον τρόπο αναδεικνύονται οι σχέσεις που υπάρχουν μεταξύ των clusters (πχ: σε μια 

τάξη μαθητών, οι σχέσεις μεταξύ αγοριών και κοριτσιών, δηλαδή ο συνολικός αριθ-

μός των τόξων που ενώνουν τις δύο αυτές ομάδες). 
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Με λίγα λόγια οι τοπικές προβολές αφορούν συνδέσεις κορυφών μέσα στο ίδιο clus-

ter, ενώ οι ευρείες προβολές, μεταξύ διαφορετικών. 

 

Ο συνδυασμός των δύο παραπάνω διαφορετικών προβολών, ονομάζεται προβολή 

συνάφειας (contextual view). Μια προβολή συνάφειας προβάλει τις σχέσεις που υ-

πάρχουν μεταξύ των clusters (πχ:΅για κάθε κορίτσι της τάξης, ποιος είναι ο συνολι-

κώς αριθμός των τόξων που συνδέεται με αγόρια). 

 

 

11. Εξαγωγή υποδικτύων 
 

Εφόσον έχουμε επιλέξει το δίκτυο και το partition που μας ενδιαφέρει, η εξαγωγή 

του υποδικτύου μπορεί να πραγματοποιηθεί επιλέγοντας Operations > Net-

work + Partition > Extract > SubNetwork. Στη συνέχεια μας ζητούνται 

οι αριθμοί και τα διαστήματα των clusters που θέλουμε να συμπεριληφθούν κατά την 

εξαγωγή: 

 

 
 

Απαραίτητη προϋπόθεση για να μπορεί να γίνει η εξαγωγή ενός υποδικτύου μέσω 

του Pajek, είναι φυσικά η ύπαρξη ενός αρχείου δικτύου (.net) κι ενός αρχείου par-

tition (.clu) το οποίο έχει προκύψει από το δίκτυο αυτό. 

 

Παράδειγμα θα μπορούσε να αποτελεί και το υποδίκτυο που προκύπτει διαχωρίζο-

ντας τις εισαγωγές και τις εξαγωγές μετάλλου, εντός μιας ηπείρου, από το παγκόσμιο 

εμπόριο μετάλλου. 
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12. Μείωση μεγέθους δικτύου 
 

Η μείωση του μεγέθους ενός δικτύου έχει πολλά πλεονεκτήματα κατά τη μελέτη του. 

Το πιο προφανές, είναι η διευκόλυνση της οπτικής παρατήρησής και της ανάλυσής 

του. Το Pajek διαθέτει αρκετά εργαλεία για το σκοπό αυτό. 

 

12.1 Μείωση – Συρρίκνωση δικτύου 

 

Η συρρίκνωση (shrinking) πραγματοποιείται επιλέγοντας Operations > Net-

work + Partition > Shrink Network. Το Pajek στη συνέχεια ζητά εισα-

χθούν τα εξής: 

 

 
 

Παράδειγμα χρήσης θα μπορούσε να αποτελεί και η συρρίκνωση του δικτύου του πα-

γκόσμιου εμπορίου μετάλλου, από το επίπεδο χωρών στο επίπεδο ηπείρων. 

 

12.2 Αφαίρεση των γραμμών με χαμηλή τιμή 

 

Ένας άλλος τρόπος μείωσης του μεγέθους ενός δικτύου, είναι η αφαίρεση γραμμών 

σύνδεσης κορυφών οι οποίες έχουν χαμηλή τιμή (ή αλλιώς αξία, ή βάρος, ή κόστος). 

 

Μπορούμε να αφαιρέσουμε τις γραμμές αυτές επιλέγοντας Network > Create 
New Network > Transform > Remove > Lines with Value > lower 

than, και δίνοντας εν συνεχεία στο Pajek, το αντίστοιχο αριθμητικό κατώφλι που θα 

λειτουργεί ως κριτήριο. 
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13. Εύρεση μονοπατιών 
 

13.1 Εύρεση συντομότερου μονοπατιού 

 

Μπορούμε να βρούμε ένα συντομότερο μονοπάτι μεταξύ δύο κορυφών επιλέγοντας 
Network > Create New Network > SubNetwork with Paths > One 

Shortest Path between Two Vertices. 

 

 

Αρχικά μας ζητούνται οι δύο κορυφές εκκίνησης και τερματισμού:  

 

 
 

Η επόμενη ερώτηση είναι η παρακάτω: 

 

 
 

Απαντούμε καταφατικά αν αναζητούμε το συντομότερο μονοπάτι με βάση τα μήκη, 

και αρνητικά αν μας ενδιαφέρουν οι τιμές των γραμμών. Τέλος, στην επόμενη ερώ-

τηση “Identify vertices in source network” απαντούμε αρνητικά. 

 

Το αποτέλεσμα είναι ένα νέο (υπό)δίκτυο που περιλαμβάνει τις δύο επιλεγμένες κο-

ρυφές με τις γραμμές που τις συνδέουν και μπορεί να απεικονιστεί επιλέγοντας Lay-

out > Energy > Kamada Kawai > Fix first and last.  

 

Στο δίκτυο που προκύπτει, οι κορυφές του συντομότερου μονοπατιού παίρνουν αύ-

ξουσα αρίθμηση από την εκκίνηση έως τον τερματισμό. Για να φανεί η αντιστοιχία 
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των κορυφών αυτών με το αρχικό δίκτυο επιλέγουμε Options > Mark Verti-

ces Using > Labels. Και για την εύρεση αλυσίδων επιλέγουμε Network > 

Create New Network > Transform > Arcs to Edges > All. 

 

Η εύρεση όλων των συντομότερων μονοπατιών μεταξύ δύο κορυφών είναι εφικτή 

επιλέγοντας Network > Create New Network > SubNetwork with 

Paths > All Shortest Paths between Two Vertices. 

 

13.2 Εύρεση διαμέτρου 

 

Επιλέγοντας Network > Create New Network > SubNetwork with 

Paths > Info on Diameter, βρίσκουμε τη διάμετρο22 του δικτύου. 

 

Μετά την εκτέλεση της εντολής αυτής, το Pajek επιστρέφει μόνο τις δύο πιο απομα-

κρυσμένες κορυφές. Αν επιθυμούμε να έχουμε και το μονοπάτι ανάμεσά τους, θα 

πρέπει στο αποτέλεσμα, να εκτελέσουμε επιπλέον και την εντολή εύρεσης του συ-

ντομότερου μονοπατιού ανάμεσα σε αυτές τις δύο κορυφές. 

 

13.3 K-neighbors 

 

Η κορυφή j είναι k-neighbor με την κορυφή i εάν το συντομότερο μονοπάτι από την 

i στην j έχει μήκος k. 

 

Στο Pajek οι αποστάσεις όλων των κορυφών από μία συγκεκριμένη κορυφή υπολο-

γίζονται επιλέγοντας Network > Create Partition > k-Neighbors > 

Output. Στη συνέχεια εισάγουμε την επιλεγμένη κορυφή και την απόσταση που θέ-

λουμε να διερευνήσουμε (εισάγοντας το μηδέν υπολογίζονται όλες οι αποστάσεις). 

 

Το αποτέλεσμα της ενέργειας αυτής, είναι ένα partition – πίνακας (2xn), όπου για 

κάθε κορυφή παίρνουμε και την αντίστοιχη απόστασή της από την επιλεγμένη. Δια-

φορετικά, θα μπορούσαμε να πούμε ότι πρόκειται για τον υπολογισμό των βημάτων 

που απαιτούνται για να φτάσουμε από την επιλεγμένη κορυφή σε όλες τις άλλες. 

 

Επιλέγοντας Network>Create Partition>k-Neighbors>Input, υπολογί-

ζουμε τα βήματα που απαιτούνται προκειμένου από όλες τις άλλες κορυφές, να φτά-

σουμε στην επιλεγμένη. 

                                                             
22 http://en.wikipedia.org/wiki/Network_science#Diameter_of_a_network 



Αριστοτέλειο Πανεπιστήμιο Θεσσαλονίκης 

Πρόγραμμα Μεταπτυχιακών Σπουδών Πληροφορικής 

 

 

46 

 

Τέλος, επιλέγοντας Network>Create Partition>k-Neighbors>All, υπο-

λογίζουμε τις αποστάσεις χωρίς να λαμβάνουμε υπόψη τις κατευθύνσεις των γραμ-

μών. 

 

Αφού υπολογιστούν οι αποστάσεις, επιλέγοντας Partition>Info, μπορούμε να 

δούμε τον αριθμό (που θα επιλέξουμε) των κοντινότερων (+) και των πιο απομακρυ-

σμένων (-) κορυφών από την επιλεγμένη κορυφή. 

 

Επίσης, μπορούμε να εξάγουμε από το δίκτυο, ένα υποδίκτυο με κορυφές που βρί-

σκονται σε συγκεκριμένη απόσταση (την οποία εισάγουμε), από την επιλεγμένη κο-

ρυφή επιλέγοντας Operations > Network + Partition > Extract 

SubNetwork. 

 

Το αποτέλεσμα μπορεί να γίνει ορατό με την απεικόνιση του δικτύου. 

 

 

14. Ισχυρά και Χαλαρά συνδεμένα στοιχεία – κορυφές 
 

Τα ισχυρά και τα χαλαρά συνδεδεμένα23 στοιχεία ενός δικτύου στο Pajek, μπορούν 

να υπολογιστούν επιλέγοντας: 

 

 
 

                                                             
23 http://en.wikipedia.org/wiki/Connectivity_(graph_theory) 
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Το αποτέλεσμα είναι ένα partition στο οποίο οι κορυφές που ανήκουν στο ίδιο στοι-

χείο (συνιστώσα) έχουν τον ίδιο αριθμό.  

 

 

15. Αμφισυνδεδεμένα στοιχεία – κόμβοι 
 

Για τον υπολογισμό αμφιστοιχείων (bicomponents) επιλέγουμε Network > Cre-
ate New Network > with Bi-Connected Components stored as 

Relation Numbers. 

 

Τα αμφισυνδεδεμένα (biconnected24 ή 2-connected) στοιχεία, αποθηκεύονται σε ιε-

ραρχίες. Ένας κόμβος σε μια ιεραρχία αντιπροσωπεύει ένα αμφισυνδεδεμένο στοι-

χείο. 

 

Σε μια ιεραρχία μπορούμε να πλοηγηθούμε όπως για παράδειγμα και στις δομές κα-

ταλόγων ενός παραθυρικού λειτουργικού συστήματος. 

 

Για την εξαγωγή ενός συγκεκριμένου αμφιστοιχείου (ή αμφικορυφής, ή αμφικόμ-

βου), επιλέγουμε Hierarchy>Extract Cluster, δίνοντας στη συνέχεια τον α-

ριθμό του κόμβου της ιεραρχίας που μας ενδιαφέρει. 

 

Για την εξαγωγή του υποδικτύου που προκύπτει από την ενέργεια αυτή, επιλέγουμε 

Operations>Network+Cluster>Extract SubNetwork. 

 

Επιπλέον, κατά τον υπολογισμό αμφιστοιχείων, το Pajek επιστρέφει ένα partition με 

τα σημεία άρθρωσης (articulation points). Οι κορυφές στο πρώτο cluster δεν αποτε-

λούν σημεία άρθρωσης (τα υπόλοιπα αποτελούν). Ο αριθμός του cluster περιλαμβά-

νει την πληροφορία σχετικά με το σε πόσα κομμάτια θα χωριστεί το (ιεραρχικό - 

δενδρικό) δίκτυο, όταν αφαιρεθεί ένα συγκεκριμένο σημείο άρθρωσης (ένωσης) από 

αυτό. 

 

 

 

 

 

                                                             
24 http://en.wikipedia.org/wiki/Biconnected_component 
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16. Άκυκλα δίκτυα 
 

Μερικά παραδείγματα άκυκλων25 δικτύων είναι τα παρακάτω: 

 

 Δίκτυα παραπομπών (citation networks) 

 Γενεαλογίες (genealogies) 

 Αλγόριθμοι εύρεσης μονοπατιών (pathfinding algorithms26) 

 

Σε ένα άκυκλο δίκτυο υπάρχουν οι πρώτες κορυφές (επίπεδο 1) στις οποίες δεν φθά-

νουν γραμμές, οι ενδιάμεσες, και οι τελικές (επίπεδο n) από τις οποίες δε ξεκινά καμία 

γραμμή σύνδεσης. Επομένως κάθε άκυκλο δίκτυο έχει ένα βάθος, το μέγεθος του ο-

ποίου εξαρτάται από το σύνολο των επιπέδων των κορυφών του. 

 

Στο Pajek τα βάθη υπολογίζονται επιλέγοντας Network > Acyclic Network 

> Depth Partition > Acyclic. 

 

 

17. Κεντρικότητα 
 

Οι επιλογές υπολογισμού της κεντρικότητας στο Pajek απεικονίζονται στην εικόνα: 

 

 
 

                                                             
25 http://en.wikipedia.org/wiki/Acyclic_graph 
26 http://en.wikipedia.org/wiki/Pathfinding 
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17.1 Βαθμός κεντρικότητας 

 

Ο βαθμός κεντρικότητας27 (degree centrality) στο Pajek υπολογίζεται επιλέγοντας 

Network > Create Partition > Degree ή Network > Create Vector 

> Centrality > Degree, και Input, Output ή All. Με την πρώτη από τις 

τρεις, παίρνουμε ένα partition ως αποτέλεσμα, ενώ με τη δεύτερη, ένα vector (οι κο-

ρυφές με το μεγαλύτερο βαθμό εμφανίζονται επιλέγοντας Vector>Info). 

 

Για τον υπολογισμό του βαθμού κεντρικότητας σε δίκτυο με βάρη (weighted degree), 

επιλέγουμε Network > Create Vector Centrality > Weighted De-

gree. 

 

17.2 Πυκνότητα κεντρικότητας 

 

Η πυκνότητα κεντρικότητας (closeness centrality28) υπολογίζεται επιλέγοντας Cre-

ate Vector > Centrality > Closeness. 

 

Όταν υπολογίζουμε την ενδιαμεσότητα σε δίκτυο με βάρη, πρέπει επιπρόσθετα να 

επιλέξουμε Input, Output ή All. Αν το δίκτυο δεν περιλαμβάνει τόξα, μπορούμε 

να επιλέξουμε, είτε Input, είτε Output. Το αποτέλεσμα σε αυτή την περίπτωση θα 

είναι το ίδιο.  

 

17.3 Ενδιαμεσότητα κεντρικότητας 

 

Η ενδιαμεσότητα κεντρικότητας (betweenness centrality29) υπολογίζεται επιλέγο-

ντας Create Vector > Centrality > Betweenness. 

 

 

18. Τριαδική απογραφή 
 

Τριαδική απογραφή (triadic census [4]) ονομάζεται η εύρεση όλων των μοτίβων 

(patterns ή cliques) τριάδων ενός κατευθυνόμενου γράφου – δικτύου. Στο Pajek η 

τριαδική απογραφή επιτυγχάνεται επιλέγοντας Network > Info > Triadic 

Census. 

                                                             
27 http://en.wikipedia.org/wiki/Centrality#Degree_centrality 
28 http://en.wikipedia.org/wiki/Centrality#Closeness_centrality 
29 http://en.wikipedia.org/wiki/Centrality#Betweenness_centrality 
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Τα συνήθη τριαδικά μοτίβα είναι 16 και φαίνονται στην εικόνα: 

 

 
 

 

19. Πυρήνες 
 

Ένα υποσύνολο κορυφών ονομάζεται k-core30 (k-πυρήνας) αν κάθε κορυφή του υ-

ποσυνόλου είναι συνδεδεμένη με τουλάχιστον k κορυφές του υποσυνόλου αυτού. 

Στην εικόνα διακρίνονται πυρήνες διαφόρων μεγεθών (0, 1, 2 και 3): 

 

 
 

Οι πυρήνες31 μπορούν να υπολογιστούν επιλέγοντας Network > Create Par-

tition > K-Core, και επιλέγοντας Input, Output ή All. Το αποτέλεσμα είναι 

                                                             
30 http://en.wikipedia.org/wiki/Degeneracy_(graph_theory) 
31 http://en.wikipedia.org/wiki/Core_(graph_theory) 
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ένα partition για κάθε κορυφή του οποίου δίνεται και ο αριθμός του πυρήνα που α-

νήκει. 

 

Στις περισσότερες περιπτώσεις ενδιαφερόμαστε μόνο για τον μεγαλύτερο πυρήνα (ή 

πυρήνες). Το αντίστοιχο υποδίκτυο μπορεί να εξαχθεί επιλέγοντας Operations > 

Network + Partition > Extract SubNetwork. Και εισάγοντας το χαμη-

λότερο και το υψηλότερο όριο του αριθμού του πυρήνα που μας ενδιαφέρει. Αν θέ-

λουμε να εξάγουμε μόνο τον μέγιστο πυρήνα, εισάγουμε τον ίδιο αριθμό δύο φορές. 

 

Ως παραδείγματα πυρήνων μπορούν να θεωρηθούν και οι πλήρεις γράφοι, οι κύκλοι 

περιττού μήκους, και κάθε δυο κύκλοι άρτιου μήκους, τις ιδιότητες των οποίων θα 

εξετάσουμε πολύ συνοπτικά σε επόμενες παραγράφους. 

 

 

20. Κλίκες 
 

Η κλίκα είναι ένας ειδικός τύπος πυρήνα. Ένα υποσύνολο ενός δικτύου ονομάζεται 

κλίκα32, εάν καθεμία κορυφή του υποσυνόλου αυτού συνδέεται με την καθεμία από 

τις άλλες κορυφές του.  

 

Η αναζήτηση κλικών είναι επεξεργαστικά πιο απαιτητική σε σχέση με την αναζήτηση 

πυρήνων. Γι’ αυτό προτιμάται συνήθως η αναζήτηση κλικών μεγέθους 3 ή 4 σε μικρά 

δίκτυα. 

 

Οι κλίκες μεγέθους 3 (3-cliques) μπορούν να δημιουργήσουν 16 διαφορετικούς τύ-

πους τριάδων (triads) όπως είδαμε και σε προηγούμενη παράγραφο. Κάνοντας ανα-

ζήτηση για κλίκες μεγέθους 3, μπορούμε να βρούμε τον αριθμό των τριάδων που 

υπάρχουν σε ένα δίκτυο. 

 

Αλλά αν θέλουμε να βρούμε όλες τις εμφανίσεις των κλικών μεγέθους 3 (δηλαδή και 

τύπους τριάδων που εμφανίζονται περισσότερες από μία φορές), θα πρέπει να κά-

νουμε χρήση μιας γενικότερης διαδικασίας, κατά την οποία γίνεται αναζήτηση τμη-

μάτων (fragments) στο δίκτυο. 

 

 

 

                                                             
32 http://en.wikipedia.org/wiki/Clique_(graph_theory) 
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21. Αναζήτηση προτύπων 
 

Ουσιαστικά, η αναζήτηση προτύπων (ή τμημάτων) σε ένα δίκτυο, είναι η διαδικασία 

κατά την οποία γίνεται μια προσπάθεια εντοπισμού μικρότερων δικτύων σε αυτό. 

Μία τέτοια αναζήτηση θα μπορούσε να αφορά την εύρεση κλικών που αποτελούνται 

από τρεις κορυφές (3-cliques). 

 

Στο Pajek, o καλύτερος τρόπος για να αναζητήσουμε ένα pattern σε ένα δίκτυο, είναι 

να το σχεδιάσουμε οι ίδιοι ως ένα νέο, ανεξάρτητο και πλήρες κατευθυνόμενο δί-

κτυο, επιλέγοντας Network > Create New Network > Complete Net-

work > Directed. 

 

Στη συνέχεια, για να καθορίσουμε αυτό το νέο μικρό δίκτυο ως fragment, το επιλέ-

γουμε (ή το ανοίγουμε) στο Pajek ώστε να είναι το πρώτο δίκτυο στην αντίστοιχη 

dropdown λίστα. Επίσης φροντίζουμε το αρχικό δίκτυο να είναι το δεύτερο. 

 

Επειδή ο αλγόριθμος αναζήτησης για fragments κάνει διάκριση μεταξύ γραμμών 

(edges) και αμφίδρομων τόξων (bidirected arcs), αν στο δίκτυο υπάρχουν γραμμές 

θα πρέπει πρώτα να μετατραπούν σε αμφίδρομα τόξα επιλέγοντας Network > 

Create New Network > Transform > Edges -> Arcs. 

 

Αφού επιλεγούν το fragment (πρώτο δίκτυο) και το αρχικό (δεύτερο) δίκτυο στο ο-

ποίο θέλουμε να εντοπίσουμε τέτοια fragments, επιλέγουμε Networks > Frag-

ment (First in Second) > Find. 

 

Ως αποτέλεσμα θα λάβουμε τα παρακάτω τρία αντικείμενα: 

 

 Ένα υποδίκτυο που περιέχει μόνο όλα τα fragments που βρέθηκαν. 

 Ένα partition με τιμές από μηδέν και άνω. Η τιμή μηδέν σημαίνει ότι η αντί-

στοιχη κορυφή δεν ανήκει σε κάποιο fragment. Μία τιμή a, σημαίνει ότι η α-

ντίστοιχη κορυφή ανήκει σε a fragments. 

 Μια ιεραρχία με όλα τα fragments 
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22. Μέθοδοι εντοπισμού δομών κοινοτήτων 
 

Οι δομές κοινοτήτων (community structures33) είναι πυκνά clusters όπου στο εσωτε-

ρικό τους υπάρχουν περισσότερες συνδέσεις απ’ ότι στο εξωτερικό τους. Ένα παρά-

δειγμα φαίνεται και στην εικόνα: 

 

 
 

Το Pajek διαθέτει δύο μεθόδους εντοπισμού δομών κοινοτήτων. Τη μέθοδο Louvain34 

και τη μέθοδο VOS clustering. 

 

 

23. Δίκτυα 2-mode 
 

Η μόνη διαφορά μεταξύ ενός συνηθισμένου δικτύου κι ενός δικτύου 2-mode35, είναι 

ότι το δεύτερο αποτελείται από δύο είδη μονάδων - υποσυνόλων (πχ: υπάλληλοι και 

εταιρείες), τα οποία συσχετίζονται με συνδέσεις. 

 

Η δημιουργία των δύο υποσυνόλων επιτυγχάνεται επιλέγοντας Network > 2-

Mode Network > Partition into 2 Modes, όπου στις κορυφές του πρώτου 

υποσυνόλου (υπάλληλοι) δίνεται ο αριθμός 1, και σε εκείνες του δευτέρου (εται-

ρείες), δίνεται ο αριθμός 2. 

                                                             
33 http://en.wikipedia.org/wiki/Community_structure 
34 http://mrvar.fdv.uni-lj.si/pajek/community/LouvainVOS.htm 
35 http://mrvar.fdv.uni-lj.si/sola/info4/uvod/twomode.pdf 
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23.1 Μετασχηματισμός 2-mode σε 1-mode 

 

Μπορούμε να μετατρέψουμε ένα 2-mode δίκτυο σε απλό (1-mode) σε δύο βήματα. 

Στο πρώτο εξάγουμε το πρώτο υποσύνολο των κορυφών επιλέγοντας Network > 

2-Mode Network > 2-Mode to 1-Mode > Rows, και έπειτα εξάγουμε το 

δεύτερο υποσύνολο επιλέγοντας Network > 2-Mode Network > 2-Mode 

to 1-Mode > Columns. 

 

Επίσης μπορούμε να δημιουργήσουμε δίκτυο με βρόχους ή χωρίς βρόχους επιλέγο-

ντας Network > 2-Mode Network > 2-Mode to 1-Mode > Include 

Loops. 

 

Για τη δημιουργία δικτύων με γραμμές οι οποίες έχουν κάποια αξία επάνω τους (για 

παράδειγμα αριθμός υπαλλήλων που δουλεύουν στη ίδια εταιρεία), ή δικτύων με 

πολλαπλές γραμμές, επιλέγουμε Network > 2-Mode Network > 2-Mode to 

1-Mode > Multiple Lines. 

 

Άλλες επιλογές μετατροπής φαίνονται και στην εικόνα: 
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24. Απεικόνιση δικτύου με βάρη 
 

Για την απεικόνιση ενός δικτύου που περιλαμβάνει βρόχους με αξίες (πχ: συνολικός 

αριθμός υπαλλήλων για κάθε εταιρεία), αποθηκεύουμε πρώτα τις αξίες αυτές σε ένα 

αρχείο vector επιλέγοντας Network > Create Vector > Get Loops, και 

στη συνέχεια χρησιμοποιούμε το vector αυτό για να καθορίσουμε τα μεγέθη των κο-

ρυφών επιλέγοντας Draw > Network + Vector.  

 

Αφού δημιουργηθεί δίκτυο με αξιολογημένες γραμμές, μπορούμε να το απεικονί-

σουμε με πολλούς τρόπους: 

 

 Απεικόνιση πλήρους δικτύου. Αρχικά απεικονίζουμε το δίκτυο χρησιμοποιώ-

ντας την μέθοδο Energy έχοντας επιλέξει Options > Values of Lines 

> Similarities (για να εμφανιστούν πιο κοντά οι γραμμές με τις υψηλό-

τερες τιμές). Οι αξίες των γραμμών μπορούν να αναπαρασταθούν επιλέγο-

ντας διαφορετικά πάχη γραμμής (Options > Lines > Different 

Widths) ή/και με χρήση διαβαθμίσεων του γκρι (Options > Lines > 

GreyScale). Αφού εξάγουμε την εικόνα σε μορφή SVG, μπορούμε να προ-

σθέσουμε γραμμές ανάλογα με την αξία τους επιλέγοντας Export > SVG 

> LineValues > Nested Classes. 

 Απεικόνιση του πιο σημαντικού μέρους του δικτύου. Εμφανίζονται μόνο οι 

γραμμές με αξία πάνω από ένα κατώφλι. Για να αποκτήσουμε μια εικόνα της 

κατανομής των αξιών αυτών, επιλέγουμε Network > Info > Line Values. Στη 

συνέχεια αφαιρούμε τις γραμμές μικρής αξίας θέτοντας το κατώφλι μέσω της 

εντολής Network > Create New Network > Transform > Re-

move > lines with value > lower than. 

 

 

25. Νησίδες 
 

Σε ένα δίκτυο όπου δίνονται ορισμένες ιδιότητες (τιμές) των κορυφών ή των γραμ-

μών, μπορούμε να βρούμε νησίδες (islands36). Οι νησίδες αυτές ονομάζονται νησίδες 

κορυφών αν δίνονται οι αξίες των κορυφών, και νησίδες γραμμών, αν δίνονται οι α-

ξίες των γραμμών. 

 

                                                             
36 http://vlado.fmf.uni-lj.si/pub/networks/doc/sunbelt/islands.pdf 
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Οι νησίδες μοιάζουν με τις κλίκες, δηλαδή, μπορούμε να τις εντοπίσουμε σε clusters 

κορυφών με αξίες σύνδεσης μεγαλύτερες εντός του cluster και μικρότερες εκτός. 

 

Για τον εντοπισμό τους θα πρέπει επίσης να επιλέξουμε το μικρότερο και το μεγαλύ-

τερο επιτρεπόμενο μέγεθος της νησίδας. Στο Pajek οι γραμμές των νησίδων υπολο-

γίζονται επιλέγοντας Network > Create Partition > Islands > Lines 

Weights. 

 

 

26. Ιεραρχικό clustering 
 

Η διαδικασία του ιεραρχικού clustering37 αποτελείται από δύο βήματα: 

 

 Υπολογισμός του dissimilarity matrix (πίνακας ανομοιοτήτων) 

 Ιεραρχικό clustering με βάση τον dissimilarity matrix που υπολογίστηκε 

 

Πριν εκτελέσουμε την παραπάνω διαδικασία, δημιουργούμε ένα πλήρες (complete38) 

cluster, επιλέγοντας Cluster > Create Complete Cluster. Με αυτό τον 

τρόπο οι ανομοιότητες (dissimilarities) θα υπολογιστούν για όλες τις μονάδες. 

 

Στη συνέχεια εκτελούμε την εντολή Operations > Network + Cluster > 

Dissimilarity > Network Based και επιλέγουμε: 

 

 d1/All αν θέλουμε να θεωρήσουμε το δίκτυο ως ένα δυαδικό πίνακα. 

 Corrected Euclidian ή Corrected Manhattan, απόσταση για δί-

κτυα με βάρη - αξίες. Σε αυτή την περίπτωση θα πρέπει να εισαχθεί και η πα-

ράμερος p (0, 1 ή 2). Η παράμετρος αυτή είναι μια οδηγίας για τον τρόπο 

υπολογισμού της διαγώνιου και της απευθείας σύνδεσης μεταξύ δύο μονά-

δων του δικτύου. 

 

Επιπλέον, μας ζητείται να ονομάσουμε το αρχείο EPS που θα δημιουργηθεί στο οποίο 

θα αποθηκευτεί το δενδρόγραμμα που θα προκύψει (το αρχείο αυτό ανοίγει με το 

λογισμικό GSView). Αν σε αυτό το σημείο θέλουμε να υπολογιστεί απλά ο dissimilar-

ity matrix και να μην προχωρήσουμε στο ιεραρχικό clustering, επιλέγουμε Cancel. 

 

 

                                                             
37 http://en.wikipedia.org/wiki/Hierarchical_clustering 
38 http://en.wikipedia.org/wiki/Complete-linkage_clustering 
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Αν επιτρέψουμε να ολοκληρωθεί το ιεραρχικό clustering, τα αποτελέσματα θα είναι: 

 

 Ο dissimilarity matrix 

 Η εικόνα EPS το δενδρογράμματος 

 Ένα αρχείο ανακατέματος .per (permutation) σύμφωνα με το δενδρό-

γραμμα το οποίο μπορεί να χρησιμοποιηθεί για την απεικόνιση του πίνακα α-

ναδιάταξης (reordered matrix) στο EPS (File > Network > Export 

Matrix to EPS > Using Permutation). 

 Ιεραρχία που αναπαριστά το ιεραρχικό clustering 

 

Στο Pajek χρησιμοποιείται από προεπιλογή η μέθοδος – κριτήριο Ward39. Για να την 

αλλάξουμε επιλέγουμε Network > Create Hierarchy > Clustering* > 

Options. 

 

 

27. Μοντελοποίηση σε μπλοκ 
 

Η μοντελοποίηση σε μπλοκ ή αλλιώς blockmodeling στο Pajek [5], μπορεί να πραγ-

ματοποιηθεί με δύο τρόπους: 

 

 Ξεκινώντας με τυχαίο partition σε δοσμένο αριθμό clusters επιλέγοντας 
Network > Create Partition > Blockmodeling* > Random 

Start. 

 Βελτιστοποιώντας το δοσμένο partition (πχ: partition που προέκυψε από ιε-

ραρχικό clustering), επιλέγοντας Network > Create Partition > 

Blockmodeling* > Optimize Partition. 

 

Αφού επιλέξουμε τον τρόπο που θα πραγματοποιηθεί το blockmodeling, επιλέγουμε: 

 

 Τον τύπο ισοδυναμίας (type of equivalence – Structural ή Reg-

ular). Μπορούμε επίσης να καθορίσουμε τους δικούς μας τύπους blocks ε-

πιλέγοντας 3-Define.  

 Τον αριθμό των επαναλήψεων 

 Τον αριθμό των clusters 

 

Αφού εισάγουμε όλες τις απαιτούμενες ρυθμίσεις επιλέγουμε Run. 

                                                             
39 http://en.wikipedia.org/wiki/Ward's_method 
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Στην περίπτωση που έχουμε επιλέξει την βελτιστοποίηση (δεύτερος τρόπος), δεν μας 

ζητείται ο αριθμός των clusters και ο αριθμός των επαναλήψεων. 

 

Το αποτέλεσμα της διαδικασίας blockmodeling στο Pajek, είναι όλα τα διαφορετικά 

partitions με την χαμηλότερη τιμή της συνάρτησης του κριτηρίου (ένα ή περισσότερα 

partitions). 

 

Τέλος, αν θέλουμε να εξάγουμε τον αναδιαταγμένο πίνακα (με γραμμές μεταξύ των 

clusters), θα πρέπει πρώτα να δημιουργήσουμε ένα permutation επιλέγοντας: Par-

tition > Make Permutation. 

 

 

28. Χρονικώς μεταβαλλόμενα δίκτυα 
 

Τα δίκτυα μεταβάλλονται με το πέρασμα του χρόνου. Στα χρονικώς μεταβαλλόμενα 

(temporal networks40) ή δυναμικά) δίκτυα, οι κορυφές και οι γραμμές δεν είναι απα-

ραιτήτως παρούσες σε κάθε στιγμή. 

 

Στο αρχείο εισόδου που δημιουργούμε για το Pajek μπορούμε για ένα δυναμικό δί-

κτυο να χρησιμοποιούμε τις παρακάτω μορφές χρονικής υπόστασης: 

 

 ti – μια μόνο χρονική στιγμή 

 ti–tj – ένα χρονικό διάστημα 

 ti-* – από μία χρονική στιγμή και μετά  

 

Για παράδειγμα, αν είχαμε ένα δυναμικό δίκτυο με κορυφές a, b, c οι οποίες εμφανί-

ζονται: 

 

 a – Σε δύο χρονικά διαστήματα. Από το 5 δευτερόλεπτο έως το 10 και από το 

12 έως το 14. 

 b – Από το διάστημα 1 έως 3 και έπειτα μόνο στο 7 

 c – Από το 4 και μετά 

 

 

 

 

                                                             
40 http://vlado.fmf.uni-lj.si/pub/networks/doc/seminar/SFI-SAS04tn.pdf 
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Και γραμμές μεταξύ των a-b, και των a-c οι οποίες εμφανίζονται: 

 

 a-b – Μόνο τη χρονική στιγμή 7 

 a-c – Στο χρονικό διάστημα 6 έως 8 

 

Το αρχείο δικτύου .net θα έπρεπε να συνταχθεί ως εξής: 

 
*Vertices 3 

1 "a" [5-10,12-14] 

2 "b" [1-3,7] 

3 "c" [4-*] 

*Edges 

1 2 1 [7] 

1 3 1 [6-8] 

 

Αφού ανοίξουμε το αρχείο .net μέσω του Pajek, επιλέγουμε Network > Tem-

poral Network > Generate in Time. 

 

Το Pajek υποστηρίζει και ένα σύνολο χρονικών συμβάντων για μεταβαλλόμενα δί-

κτυα πραγματικού χρόνου. Τα συμβάντα αυτά περιγράφονται στον πίνακα που ακο-

λουθεί: 
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Το παρακάτω κείμενο είναι ένα παράδειγμα αρχείου δικτύου με χρονικά συμβάντα: 

 
*Vertices 3 

*Events 

TI 1 

AV 2 "b" 

TE 3 

HV 2 

TI 4 

AV 3 "c" 

TI 5 

AV 1 "a" 

TI 6 

AE 1 3 1 

TI 7 

SV 2 

AE 1 2 1 

TE 7 

DE 1 2 

DV 2 

TE 8 

DE 1 3 

TE 10 

HV 1 

TI 12 

SV 1 

TE 14 

DV 1 

 

 

29. Συνδεσιμότητα μικρών κύκλων 
 

Η συνδεσιμότητα μικρών “κύκλων” (short cycle connectivity [6]), είναι μια γενίκευση 

της συνήθους σύνδεσης. Αντί ενός μονοπατιού (ακολουθία γραμμών σύνδεσης), δύο 

κορυφές πρέπει να συνδέονται από μια ακολουθία συνδέσεων που σχηματίζουν μι-

κρούς κύκλους (πχ: τριάδες) όπου οι δύο γειτονικοί κύκλοι θα πρέπει να έχουν του-

λάχιστον μια κοινή κορυφή μεταξύ τους. Αν αυτό συμβαίνει σε όλους τους 

παρακείμενους κύκλους, τότε μπορούμε να μιλάμε για συνδεσιμότητα μικρών κύ-

κλων ή αλλιώς, δακτυλίων (rings). 
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Στην εικόνα βλέπουμε ένα παράδειγμα συνδεσιμότητας μικρών κύκλων (T1 έως Τ6) 

οι οποίοι σχηματίζουν τριγωνική αλυσίδα (και μονοπάτι u – v): 

 

 
 

Μέσω του Pajek μπορούμε να δημιουργήσουμε δίκτυα μικρών κύκλων που οι δακτύ-

λιοί τους να είναι τριγωνικοί (3-Rings) επιλέγοντας Network > Create New 

Network > with Ring Counts stored as Line Values > 3-Rings, 

ή τετραγωνικοί (4-Rings), επιλέγοντας Network > Create New Network > 

with Ring Counts stored as Line Values > 4-Rings.  

 

Οι δακτύλιοι μπορεί να είναι κατευθυνόμενοι ή μη κατευθυνόμενοι. 

 

 

30. Εξαγωγή δεδομένων 
 

Μέσω του μενού Tools το Pajek διαθέτει τη δυνατότητα εξαγωγής δεδομένων σε διά-

φορες μορφές (τύπους αρχείων) για την περαιτέρω ανάλυσή τους από άλλα λογι-

σμικά. 

 

30.1 Εξαγωγή στην R 

 

Τα δίκτυα και τα διανύσματα μπορούν να εξαχθούν από το Pajek για το στατιστικό 

πακέτο R41 (και το αντίστροφο). Με τη γλώσσα R μπορούμε να πραγματοποιήσουμε 

στατιστική ανάλυση στα δεδομένα αυτά. 

 

Για παράδειγμα, μπορούμε να εξάγουμε διανύσματα τα οποία περιλαμβάνουν τα δε-

δομένα για την πυκνότητα (closeness) και την ενδιαμεσότητα (betweenness) της κε-

ντρικότητας (centrality) ενός δικτύου, στην R, και να εκτελέσουμε τις παρακάτω 

ενέργειες: 

 

 

                                                             
41 http://cran.r-project.org 
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 Σχεδίαση διαγράμματος διασποράς (scatterplot) 

 Σχεδίαση ιστογράμματος 

 Υπολογισμός συσχέτισης μεταξύ των δύο μετρήσεων 

 

Για να συνεργαστεί το Pajek με την R θα πρέπει να εντοπιστεί το εκτελέσιμο της R 

που δημιουργεί τα γραφικά επιλέγοντας Tools > R > Locate R (εντοπισμός 

του αρχείου C:\Program Files\...\bin\Rgui.exe ή του αρχείου 

Rterm.exe). Αφού γίνει αυτό τα δεδομένα μπορούν να σταλούν επιλέγοντας 

Tools > R > Send to R. 

 

30.2 Εξαγωγή σε SPSS 

 

Προκειμένου να συνδέσουμε το Pajek με τη σουίτα SPSS, επιλέγουμε Tools > 

SPSS > Locate SPSS και εντοπίζουμε το αρχείο runsyntx.exe που βρίσκεται 

συνήθως στον κατάλογο C:\Program Files\SPSS. 

 

Στη συνέχεια μπορούμε να στείλουμε δίκτυα, partitions και vectors, επιλέγοντας 

Tools > SPSS > Send to SPSS. 

 

30.3 Εξαγωγή σε αρχείο χωρισμένο με tabs 

 

Εξαγωγή partitions και vectors σε αρχείο το οποίο μπορεί στη συνέχεια να διαβαστεί 

από κάποιο άλλο στατιστικό πακέτο (πχ: Stata), ή από το Excel. 

 

 

31. Σενάριο χρήσης με πραγματικά δεδομένα 
 

Σε αυτή την παράγραφο θα εξετάσουμε ένα σενάριο χρήσης του Pajek σε πραγματικά 

δεδομένα42, που αφορούν το παγκόσμιο εμπόριο μετάλλου (το έτος 1994), και το ο-

ποίο χρησιμοποιήθηκε ως παράδειγμα και σε προηγούμενη παράγραφο. 

 

Τα τόξα του δικτύου (Imports_manufactures.net) αντιπροσωπεύουν τις ει-

σαγωγές μετάλλου που κάνει μία χώρα από μία άλλη. Αφού εισάγουμε το αρχείο του 

δικτύου στο Pajek (File>Network>Read>Imports_manufactures.net), ε-

πιλέγουμε Draw>Network και προκύπτει ο παρακάτω γράφος: 

 

                                                             
42 http://vlado.fmf.uni-lj.si/pub/networks/data/esna/metalWT.htm 
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Το μέγεθος των κόκκινων κουκίδων εισάγεται από εμάς μέσω του μενού, επιλέγο-

ντας Options>Size>Of Vertices. Τα βάρη των συνδέσεων ενεργοποιούνται 

και απενεργοποιούνται μέσω του Options>Lines>Mark Lines. 
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Μια πιο ευκρινής απεικόνιση του δικτύου:  

 

 
 

Εύκολα παρατηρούμε από την εικόνα ότι σχηματίζονται τρεις νοητοί «ομόκεντροι» 

κύκλοι. Τρεις ομάδες χωρών. Η κεντρική ομάδα αποτελεί τον πυρήνα43 του εμπορίου 

του μετάλλου, και καθώς κινούμαστε προς τα έξω, συναντάμε τις χώρες που παίζουν 

δευτερεύων και τριτεύων ρόλο, αντιστοίχως. Αυτό είναι το πρώτο και το ευκολότερο 

συμπέρασμα που μπορούμε να βγάλουμε. 

 

                                                             
43 Με τον όρο «πυρήνας» εννοούμε τις χώρες που παίρνουν τις πρώτες ύλες από τις (βλ βιβλιο)+++++ 
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Είναι προφανές ότι ο αριθμός των γραμμών είναι αρκετά μεγάλος και δυσχεραίνει 

την περεταίρω οπτική ανάλυση του δικτύου μας. Για το λόγο αυτό θα πρέπει να επι-

λεγεί κάποιο κριτήριο - εργαλείο απλοποίησης ή σήμανσης που θα μας επιτρέψει να 

βγάλουμε επιπλέον συμπεράσματα. 

 

Ένας τρόπος για να επιτευχθεί κάτι τέτοιο, είναι η διαμέριση (partitioning) του δι-

κτύου των χωρών σε ηπείρους. Αυτό επιτυγχάνεται μέσω της εισαγωγής του αντί-

στοιχου αρχείου (File>Partition>Read>Continent.clu). Μετά την 

ολοκλήρωση της εισαγωγής, θα πρέπει να επιβεβαιώσουμε οπτικά ότι το αρχείο δια-

μέρισης .clu έχει τον ίδιο αριθμό κόμβων με το αρχείο του δικτύου .net (που στην 

περίπτωσή μας είναι 80): 

 

 
 

Κάνοντας κλικ στο εικονίδιο του μεγεθυντικού φακού (View/Edit Partition) 

κάτω από το κουμπί Partition, μπορούμε να δούμε την διαμέριση βάσει των η-

πείρων: 
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Η στήλη Vertex συμβολίζει τις κορυφές του δικτύου και παίρνει τιμές 1 – 80 (αριθ-

μός συμμετεχουσών χωρών). Η στήλη με το όνομα Val παίρνει τιμές 1 – 6 και 

συμβολίζει τις 6 από τις 7 ηπείρους, μιας και δεν υπάρχουν χώρες που να αντιπρο-

σωπεύουν την έβδομη (πιθανότατα επειδή δεν συμμετέχουν στο δίκτυο εισαγωγών 

μετάλλου). Η Ελλάδα ανήκει στην Ευρώπη, επομένως εύκολα βγαίνει το συμπέρασμα 

ότι όποια χώρα (Label) έχει την τιμή (Val) 3, ανήκει στην Ευρώπη. 

 

Επιλέγοντας Draw>Network + First Partition, παίρνουμε μία λίγο πιο 

κατατοπιστική απεικόνιση του δικτύου, μιας και το Pajek εφαρμόζει αυτόματα δια-

φορετικό χρώμα για καθεμιά από τις 6 ηπείρους: 
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Η εμφάνιση του αριθμού της ηπείρου εφαρμόζεται επιλέγοντας Options>Mark 

Vertices Using>Partition Clusters. 

 

Με μια σύντομη παρατήρηση συμπεραίνουμε ότι κάποιες χώρες της Ευρώπης (κόκ-

κινο χρώμα) ανήκουν στον πυρήνα, ενώ κάποιες άλλες όχι. Οι χώρες εκτός πυρήνα 

είναι σίγουρα κατώτερες οικονομικά από τις χώρες εντός. 

 

Παρ’ όλα αυτά, το δίκτυό μας συνεχίζει να περιέχει αρκετή ακόμα πληροφορία που 

δυσχεραίνει την παρατήρησή του. Μία από τις πρώτες επεμβάσεις που μπορούν να 

γίνουν, είναι η συρρίκνωση του δικτύου. Αυτό μπορεί να γίνει αφού πρώτα θέσουμε 

ένα λογικό στόχο, όπως είναι για παράδειγμα η αναπαράσταση της συσχέτισης στο 

εμπόριο μετάλλου μεταξύ των 6 ηπείρων που συμμετέχουν. 

Επιλέγοντας από το κεντρικό μενού του Pajek, Operations>Network+Parti-

tion>Shrink Network, εμφανίζεται το παρακάτω παράθυρο διαλόγου, στο ο-

ποίο ζητείται να εισαχθεί ο ελάχιστος αριθμός συνδέσεων μεταξύ των clusters του 

partition και ο αριθμός του cluster που δεν επιθυμούμε να συρρικνωθεί: 
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Ως αποτέλεσμα παίρνουμε κάτι πολύ πιο ευανάγνωστο αλλά με ορισμένα σημεία στα 

οποία απαιτείται από εμάς χειροκίνητη διόρθωση: 

 

 
 

Πρέπει οι κορυφές του νέου δικτύου να αποτελούνται μόνο από ονόματα ηπείρων. 

Επομένως θα πρέπει να γίνει ανάλογη επεξεργασία στη νέα αυτή διαμέριση που έχει 

προκύψει μετά τη συρρίκνωση: 
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Η αλλαγή των ονομάτων γίνεται στα πεδία της στήλης Label: 

 

 
 

Και το νέο δίκτυο αποτελείται πλέον, μόνο από τα ονόματα των 6 ηπείρων: 

 

 
 

Αν και ο παραπάνω γράφος είναι αρκετά απλός, είναι λίγο δύσκολο κάποιος να μπο-

ρέσει να καταλάβει αν είναι πλήρης. Η χρήση ενός πίνακα γειτνίασης (adjacency ma-

trix) μπορεί να προσφέρει μια καλύτερη εικόνα. Μέσα από το κεντρικό μενού του 

Pajek επιλέγουμε File>Network>Export as Matrix to EPS>Using 

Partition>Structural.Στα παράθυρα διαλόγου που θα προκύψουν αφήνουμε 
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τις προεπιλεγμένες τιμές και σώζουμε το αρχείο που περιλαμβάνει τον πίνακα γειτ-

νίασης στο αρχείο adjacency_matrix.eps. 

 

Στη συνέχεια, αν στο σύστημά μας υπάρχει εγκατεστημένο το απαιτούμενο λογι-

σμικό44, μπορούμε να προβάλουμε τον πίνακα γειτνίασης κάνοντας διπλό κλικ στο 

αντίστοιχο αρχείο: 

 

 
 

Είναι προφανές με την πρώτη ματιά, ότι ο γράφος μας δεν είναι πλήρως συνδεδεμέ-

νος και ότι ο παραπάνω πίνακας δεν είναι συμμετρικός. Δηλαδή, το εμπόριο μετάλ-

λου δεν πραγματοποιείται από, και προς, όλες τις ηπείρους. Για παράδειγμα, η 

Αυστραλία δε συναλλάσσεται με την Αφρική. 

 

Σε αυτό το σημείο έχει επίσης νόημα, να υπολογίσουμε το μέγεθος της ενδιαμεσότη-

τας (betweenness45) δημιουργώντας ένα διάνυσμα μέσω του Pajek. Από το κεντρικό 

                                                             
44 Ghostscript και GSview: http://pages.cs.wisc.edu/~ghost/ 
45 http://en.wikipedia.org/wiki/Betweenness_centrality 
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μενού επιλέγουμε Network>Create Vector>Centrality>Betweenness. 

Το νέο διάνυσμα εμφανίζεται στο αντίστοιχο πεδίο: 

 

 
 

Κάνοντας κλικ στο εικονίδιο με τον μεγεθυντικό φακό που βρίσκεται κάτω από το 

κουμπί Vectors, εμφανίζεται ο πίνακας με τις τιμές που αφορούν την ενδιαμεσότητα 

της κάθε Ηπείρου: 

 

 
 

Όπως ήταν ίσως αναμενόμενο, η ήπειρος της Ασίας παρουσιάζει τη μεγαλύτερη εν-

διαμεσότητα. Αυτό σημαίνει ότι στο παγκόσμιο εμπόριο του μετάλλου (το έτος 1994) 

οι ασιατικές χώρες παίζουν κομβικό ρόλο και έχουν το μεγαλύτερο μερίδιο των συ-

ναλλαγών. 
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Αυτό είναι ακόμα πιο προφανές αν το διάνυσμα παρουσιαστεί γραφικά, επιλέγοντας 

Draw > Network + First Vector: 
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32. Παραρτήματα 
 

32.1 Τα περιεχόμενα του αρχείου mynetwork.net 
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32.2 Οι κώδικες των αρχείων Matlab 

 

32.2.1 Ο κώδικας του αρχείου  get_random_graph.m 

 
function [ G ] = get_random_graph( N, K ) 

 

if N < 2 

    error('N must be at least 2'); 

end 

 

if K < 1 

    error('K must be at least 1'); 

end 

 

G = zeros(N); 

 

% For each vertex, connect its K closest neighbours 

 

p = K / N; 

 

for i = 1 : N 

   count = 0; 

   for j = i + 1 : N 

       if rand < p 

           G(i,j) = 1; 

           G(j,i) = 1; 

           count = count + 1; 

       end 

   end 

   if count == 0 

      % ensure at least one edge 

      j = round(rand * N); 

      while (j < 1 || j == i || j > N) 

          j = round(rand * N); 

      end 

      G(i,j) = 1; 

      G(j,i) = 1; 

   end 

end 
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32.2.2 Ο κώδικας του αρχείου write_matrix_to_pajek.m 

 
function write_matrix_to_pajek(matrix, path, varargin) 

 

p.weighted=true; 

p.threshold_low=0; 

p.threshold_high=realmax; 

p.directed=true; 

p.labels={}; 

p.coords={}; 

 

validParams     = {     ... 

  'weighted',          ... 

  'threshold_low',            ... 

  'threshold_high',       ... 

  'directed',      ... 

  'labels',      ... 

  'coords',      ... 

  }; 

 

if nargin > 2 

  if mod( numel( varargin ), 2 ) ~= 0 

    error( 'write_matrix_to_pajek:InvalidInput', ['All 

input parameters after the fileName must be in the ' ... 

      'form of param-value pairs'] ); 

  end 

  params  = lower( varargin(1:2:end) ); 

  values  = varargin(2:2:end); 

 

  if ~all( cellfun( @ischar, params ) ) 

    error( 'write_matrix_to_pajek:InvalidInput', ['All 

input parameters after the fileName must be in the ' ... 

      'form of param-value pairs'] ); 

  end 

 

  lcValidParams   = lower( validParams ); 

  for ii =  1 : numel( params ) 

    result        = strmatch( params{ii}, lcValidParams 

); 

    % If unknown param is entered ignore it 

    if isempty( result ) 

      continue 

    end 

    % If we have multiple matches make sure we don't have 

a single unambiguous match before throwing 

    % an error 

    if numel( result ) > 1 
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      exresult    = strmatch( params{ii}, validParams, 

'exact' ); 

      if ~isempty( exresult ) 

        result    = exresult; 

      else 

        % We have multiple possible matches, prompt user 

to provide an unambiguous match 

        error( 'write_matrix_to_pajek:InvalidInput', 

'Cannot find unambiguous match for parameter ''%s''', ... 

          varargin{ii*2-1} ); 

      end 

    end 

    result      = validParams{result}; 

    p.(result)  = values{ii}; 

  end 

end 

 

[fid, msg] = fopen(path, 'w'); 

 

if fid < 0 

    error('write_matrix_to_pajek:InvalidPath', 'Could not 

open %s for writing: %s', path, msg); 

end 

 

 

if size(matrix,1)~=size(matrix,2) 

   error('write_matrix_to_pajek:InavlidMatrix', 'Matrix 

must be square.'); 

end 

 

N=size(matrix,1); 

 

% Write vertices 

fprintf(fid,'*vertices %i', N); 

for i = 1 : N 

    

    fprintf(fid, '\n %i', i); 

    if (~isempty(p.labels)) 

        fprintf(fid, ' "%s"', char(p.labels(i))); 

    else 

        fprintf(fid, ' "%i"', i); 

    end 

    if (~isempty(p.coords)) 

        fprintf(fid, ' %f %f %f', p.coords(i,1), 

p.coords(i,2), p.coords(i,3)); 

    end 

    

end 
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% Write edges 

if p.directed == true 

    fprintf(fid,'\n*arcs'); 

else 

    fprintf(fid,'\n*edges'); 

end 

 

for i = 1 : N 

    start = 1; 

    if (p.directed ~= true) 

        start = i; 

    end 

    for j = start : N 

        if (i ~= j) 

            value = matrix(i,j); 

            if value > p.threshold_low && value < 

p.threshold_high 

                fprintf(fid, '\n %i %i', i, j); 

                if p.weighted == true 

                    fprintf(fid, ' %f', value); 

                end 

            end 

        end 

    end 

end 

 

fclose(fid); 
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32.3 Εύρεση του συντομότερου μονοπατιού με τη βοήθεια βιολογικών οργα-

νισμών που δε διαθέτουν εγκέφαλο 

 

Η θεωρία γράφων ορίζεται με μαθηματικά μοντέλα. Τα μαθηματικά είναι ένα ανθρώ-

πινο εργαλείο για την περιγραφή των φαινομένων που ο άνθρωπος μπορεί να αντι-

ληφθεί με τα αισθητήρια όργανά του, αλλά και με τα τεχνολογικά εργαλεία μέτρησης 

που ο ίδιος έχει αναπτύξει. Όλα αυτά έγιναν εφικτά λόγω της εγκεφαλικής του δομής 

και δραστηριότητας. 

 

Για τους εξελικτικούς βιολόγους, η ανάπτυξη του εγκεφάλου δεν είναι αποτέλεσμα 

συμπαντικής σκοπιμότητας. Προέκυψε σε βάθος εκατομμυρίων ετών εξέλιξης, μέσω 

τυχαίων φυσικών και χημικών γεγονότων. Είναι δηλαδή προϊόν ενός χημικού μονο-

πατιού το οποίο οι φυσικοί νόμοι επιτρέπουν να υπάρχει και να εκφράζεται. 

 

Πιθανή ένδειξη ορθότητας της ιδέας αυτής, θα μπορούσε να αποτελεί μια πρόσφατη 

επιστημονική έρευνα κατά την οποία οι ερευνητές απέδειξαν ότι ένα είδος ευκαρυω-

τικού οργανισμού που ανήκει στα πρώτιστα46, μπορεί να «υπολογίσει» το συντομό-

τερο μονοπάτι σε ένα γράφο ή σε ένα λαβύρινθο47, 48. Η επιστημονική του ονομασία 

είναι Physarum polycephalum49: 

 

 
 

                                                             
46 http://en.wikipedia.org/wiki/Protist 
47 https://youtu.be/lls27hu03yw 
48 https://youtu.be/czk4xgdhdY4 
49 http://en.wikipedia.org/wiki/Physarum_polycephalum 
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Δεν διαθέτει εγκέφαλο, ούτε κάποιου είδους νευρικό σύστημα. Όμως, παρ’ όλα αυτά, 

είναι σε θέση να λαμβάνει αρκετά σύνθετες «αποφάσεις». Για παράδειγμα, μπορεί να 

βρει το συντομότερο μονοπάτι μέσα από έναν λαβύρινθο50 προκειμένου να προσεγ-

γίσει την τροφή που βρίσκεται στην έξοδο του λαβυρίνθου αυτού. 

 

Αρχικά επεκτείνει τους δενδρίτες51, 52 του σε όλους τους διαδρόμους χαρτογραφώ-

ντας έτσι ολόκληρο το λαβύρινθο (a). Στη συνέχεια αποσύρει τον κάθε βλαστό που 

δεν «εντόπισε» τροφή (b) αφήνοντας πίσω ένα είδος λάσπης που λειτουργεί σαν ε-

ξωτερική μνήμη η οποία υπενθυμίζει στο Physarum τα αδιέξοδα μονοπάτια. Αποφεύ-

γοντας τα μονοπάτια αυτά, φύεται αποκλειστικά κατά μήκος της συντομότερης 

διαδρομής (c) από την αρχή του λαβυρίνθου ως την τροφή . 

 

 
 

Με τη βοήθεια του Physarum, ομάδα επιστημόνων κατάφερε να υπολογίσει με ακρί-

βεια το σιδηροδρομικό σύστημα του Τόκυο53 (στάδια A έως F σε χρονικό διάστημα 26 

ωρών): 

 

 

                                                             
50 http://arxiv.org/pdf/1106.0423v3.pdf 
51 https://vimeo.com/67686724 
52 https://youtu.be/mvBSkt6LhJE 
53 https://youtu.be/BZUQQmcR5-g 
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Επίσης, υπολόγισαν και τους σημαντικούς δρόμους της Αγγλίας, του Καναδά, της Ι-

σπανίας και της Πορτογαλίας. Ένα απλό κύτταρο, κατάφερε να επιλύσει πραγματικά 

προβλήματα για τα οποία θα απαιτούνταν άρτια εκπαιδευμένες ομάδες μηχανικών 

και εκατοντάδες ώρες εργασίας. 

 

Το γεγονός αυτό είναι βέβαιο ότι θα αλλάξει τον τρόπο με τον οποίο η επιστημονική 

κοινότητα αντιμετωπίζει τον εγκέφαλο. Επίσης θα εμπνεύσει την ανάπτυξη νέων με-

θόδων ανάλυσης γράφων, αλλά και νέων βιομαθηματικών μοντέλων. 
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