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Η εφαρμογή Pajek
Χρησιμοποιείται για την ανάλυση και απεικόνιση μεγάλων δικτύων.
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Πανεπιστήμιο
της Λιουμπλιάνα

Σλοβενία

Γενικές πληροφορίες για το Pajek

 Η ανάπτυξή του ξεκίνησε το 1996
 Έχει γραφτεί σε Delphi
 Μόνο για το λειτουργικό σύστημα Windows
 Διατίθεται σε 32 και 64bit εκδόσεις
 Είναι δωρεάν, αλλά όχι ανοικτό λογισμικό
 Διαθέσιμο για μη εμπορική χρήση
 Η λέξη “Pajek” στα σλοβενικά σημαίνει “αράχνη”

Μια ειδική έκδοση του Pajek, είναι το Pajek–XXL. Έχει
σημαντικά λιγότερες απαιτήσεις σε μνήμη (2 έως 3 φορές)
και είναι ταχύτερο σε περιπτώσεις διεργασιών με συχνή
χρήση μνήμης (π.χ. παραγωγή τυχαίων δικτύων, εξαγωγή
δεδομένων δικτύων, συρρίκνωση δικτύων κ.α.).

Χρησιμοποιείται ευρέως στην επιστημονική έρευνα

Vladimir Batagelj
Μαθηματικός
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Γενικά χαρακτηριστικά
Δίκτυα που υποστηρίζει το Pajek και δυνατότητες υπολογισμών στα δίκτυα αυτά.
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Δίκτυα που αναλύονται ή/και 
απεικονίζονται με το Pajek:

 Δίκτυα οργανικών μορίων
 Αλληλεπιδράσεις δικτύων 

πρωτεϊνών - υποδοχέων
 Κοινωνικά δίκτυα
 Γενεαλογικά δέντρα
 Δίκτυα Internet
 Δίκτυα βιβλιογραφικών 

παραπομπών
 Δίκτυα διάχυσης

(ιών, ειδήσεων κ.α.)
 Και πολλά άλλα

Με το Pajek είναι δυνατή:

 Η εύρεση συστάδων (υποσύνολα, 
γειτονικές κορυφές που 
παρουσιάζουν κάποιο νόημα, 
πυρήνες, κλπ.) σε ένα δίκτυο.

 Η εξαγωγή κορυφών που ανήκουν 
σε ίδιες συστάδες και η 
παρουσίασή τους ξεχωριστά 
(λεπτομερής τοπική θέαση).

 Η συμπύκνωση κορυφών σε 
συστάδες.

 Η παρουσίαση των σχέσεων που 
υπάρχουν μεταξύ συστάδων 
(ευρεία σφαιρική θέαση).

Τύποι δικτύων που υποστηρίζονται

 Πολυσχεσιακά δίκτυα
 Δίκτυα 2-mode (διμερείς 

γράφοι)
 Δυναμικά δίκτυα

Ένα δίκτυο αποτελείται από ένα 
γράφο και ορισμένες 
συμπληρωματικές πληροφορίες 
σχετικά με τις κορυφές ή/και τις 
γραμμές του γραφήματος.

Τι είναι δίκτυο
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Οι τύποι δεδομένων που υποστηρίζει το Pajek
Το Pajek υποστηρίζει έξι διαφορετικούς τύπους δεδομένων (δίκτυα, κατατμήσεις, διανύσματα, μεταθέσεις, συστάδες και ιεραρχίες).
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.net

Δίκτυα (Networks)

Στο Pajek τα δίκτυα είναι τα κύρια 
αντικείμενα. Ένα δίκτυο αποτελείται 
από ένα γράφο και ορισμένες 
συμπληρωματικές πληροφορίες 
σχετικά με τις κορυφές ή/και τις 
γραμμές του γραφήματος αυτού.

.per

Μεταθέσεις (Permutations)

Μια μετάθεση ενός δικτύου είναι μια 
νέα αρίθμηση (δηλαδή μια 
αναδιάταξη) των κορυφών του. 

.clu

Κατατμήσεις (Partitions)

Ένα διαμέρισμα ενός δικτύου είναι μια 
ταξινόμηση ή ομαδοποίηση των 
κορυφών του δικτύου, έτσι ώστε κάθε 
κορυφή έχει εκχωρηθεί σε ακριβώς 
μία κλάση (ή ένα σύμπλεγμα).

.cls

Συστάδες (Clusters)

Μια συστάδα είναι ένα υποσύνολο των 
κορυφών ενός δικτύου.

.vec

Διανύσματα (Vectors)

Ένα διάνυσμα περιλαμβάνει και 
εκχωρεί μια αριθμητική τιμή για κάθε 
κορυφή ενός δικτύου.

.hie

Ιεραρχίες (Hierarchies)

Μια ιεραρχία περιλαμβάνει ιεραρχικά 
ταξινομημένες κορυφές ενός δικτύου.

Σε ένα Partition, μια κορυφή (ή group κορυφών) δεν μπορεί να ανήκει ταυτόχρονα σε περισσότερες από μία κλάσεις όπως συμβαίνει σε μια ιεραρχία.

Διαφορά Partition από Hierarchy
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Το γραφικό περιβάλλον εργασίας του Pajek
Το κεντρικό παράθυρο της εφαρμογής αποτελείται από δύο περιοχές. Την περιοχή του κυρίως μενού (Κόκκινη – Α) και την περιοχή των δεδομένων (Κίτρινη Β).
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Τα στοιχεία ελέγχου της περιοχής Β

Είναι το Βασικό περιβάλλον εργασίας.

6 μεγάλα κουμπιά: Προσθήκη – αφαίρεση 
πεδίων εισαγωγής, σε όσα είναι στον 
πληθυντικό.

Drop-down lists:
 Πολλαπλά αρχεία δεδομένων
 Πράξεις μεταξύ αρχείων
 Απεικόνιση επιλεγμένου αρχείου

Εικονίδια:
 Άνοιγμα – εισαγωγή αρχείου (φάκελος)
 Αποθήκευση αλλαγών (δισκέτα)
 Επεξεργασία ιδιοτήτων  (φακός)
 Λήψη πληροφοριών με κριτήριο (info)
 Απεικόνιση δικτύου (μολύβι)

Checkboxes: Μορφοποίηση της εμφάνισης 
των αντικειμένων κατά την απεικόνισή τους, 
όταν υπάρχουν πολλά όμοια αντικείμενα.Μοιάζει με ένα επιστημονικό κομπιουτεράκι για μαθηματικές πράξεις σε δίκτυα
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Δομή αρχείου .net
Σε ένα αρχείο .net περιλαμβάνονται όλες οι πληροφορίες σχεδίασης και απεικόνισης των πρωτογενών δεδομένων του δικτύου.
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Αρχείο κατευθυνόμενου δικτύου 7 κορυφών, 3 τόξων και δύο γραμμών.
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Παράδειγμα: Μαϊμού Wolfe (2-mode network)
Τα δεδομένα αφορούν τις αλληλεπιδράσεις, το φύλο, την ηλικία και το ranking των ατόμων αυτού του είδους μαϊμούς.
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Εντολή απεικόνισης δικτύου:  Draw > Network + First Partition + First Vector
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Δημιουργία αρχείων δικτύου για το Pajek
Οι έξι βασικότεροι τρόποι δημιουργίας αρχείων .net. Υπάρχουν και άλλοι τρόποι, όπως για παράδειγμα, μέσω άλλων γλωσσών προγραμματισμού.
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MatlabPajek Επεξεργαστής Κειμένου

Σχεσιακή Βάση ΔεδομένωνExcel2Pajek.exePython
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Δημιουργία αρχείου δικτύου με το Pajek
Έχει νόημα όταν εισάγουμε πρωτογενή δεδομένα τα οποία έχουμε συλλέξει οι ίδιοι και θα πρέπει να εισαχθούν χειροκίνητα.
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1 Network > Create Random Network > Total No. of Arcs

3 Draw > Network

2

6

File > Network > View/Edit
Για προσθήκη συνδέσεων5

4 Εμφανίζεται ασύνδετος γράφος (αφού Arcs=0)

7

8

9
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Δημιουργία αρχείου δικτύου με κειμενογράφο 
Έχει νόημα για πρωτογενή δεδομένα, τα οποία έχουμε συλλέξει οι ίδιοι και πρέπει στη συνέχεια να τα εισάγουμε χειροκίνητα.
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Αρχείο κατευθυνόμενου δικτύου 7 κορυφών, 3 τόξων και δύο γραμμών.

Σύνταξη αρχείου .net σε κειμενογράφο

Η πρώτη γραμμή (*Vertices 7) ακολουθείται από επτά

γραμμές οι οποίες περιλαμβάνουν τις επτά κορυφές του

δικτύου. Καθεμιά από αυτές τις γραμμές περιλαμβάνει

αντίστοιχα, τον αριθμό της κορυφής (1 έως 7), το σύμβολό

της (v1 έως v7), και τρείς τιμές που αντιπροσωπεύουν τις

συντεταγμένες της στο χώρο (x, y, z). Δεν επιτρέπονται

κενές γραμμές και tabs.

Κάτω από την γραμμή με την επικεφαλίδα *Arcs,

υπάρχουν τρεις γραμμές που αφορούν τα τόξα

κατευθυνόμενων συνδέσεων. Ο πρώτος αριθμός αφορά

την κορυφή από την οποία ξεκινά το βέλος και ο

δεύτερος, την κορυφή στην οποία δείχνει. Ο τρίτος

επηρεάζει το στυλ της γραμμής. Για παράδειγμα αν έχει

αρνητικό πρόσημο σχεδιάζεται διακεκομμένη.

Τέλος, οι μη-κατευθυνόμενες συνδέσεις περιγράφονται

κάτω από τον τίτλο *Edges.

Το Pajek, επιτρέπει επιπλέον μορφοποίηση και καθορισμό των χαρακτηριστικών των στοιχείων που ανήκουν στο δίκτυο (συντεταγμένες των κορυφών στο χώρο,
σχήμα και χρώμα των κορυφών και των γραμμών). Για παράδειγμα, η λέξη ”box” δίπλα από μια κορυφή, την κάνει να εμφανίζεται με τετραγωνάκι αντί κύκλου.

Μορφοποίηση του στυλ εμφάνισης
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Δημιουργία αρχείου δικτύου με το Matlab
Το Matlab αποτελεί πανίσχυρο εργαλείο για την επιστημονική έρευνα και η επικοινωνία του με το Pajek είναι αρκετά χρήσιμη.
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Συναρτήσεις Matlab

 get_random_graph() – Επιστρέφει ένα μη-κατευθυνόμενο, 
τυχαίο δίκτυο 20 κόμβων, με μέσο όρο 3 συνδέσεις ανά 
κόμβο (πιθανότητα 3/20 ή 15%), σε μορφή .mat.

 write_matrix_to_pajek() – Μετατρέπει δεδομένα Matlab που 
βρίσκονται σε μορφή .mat, σε αρχείο δικτύου Pajek μορφής 
.net.

Σενάριο: Νευρωνικές συνδέσεις μεταξύ διαφορετικών 

εγκεφαλικών περιοχών.

Βήματα

1. ΑΜ = get_random_graph(20,3)
2. Τα περιεχόμενά του είναι όμως μηδενικά και άσσοι. Επειδή 

θέλουμε το δίκτυό μας να είναι κατευθυνόμενο, εκτελούμε
 AM = AM.*rand(20);

3. coordinates = rand(20,3) (για μετατροπή σε 3D)
4. write_matrix_to_pajek(AM,'random.net','weighted',true,'di

rected',false,'coords',coordinates);

5. Ανοιγμα του αρχείου random.net με το Pajek

6. Απεικόνιση (περιστροφή με τα πλήκτρα x,y,z)

Ο πίνακας γειτνίασης ΑΜ

coordinates =

0.5312 0.7067 0.3508 (1η γραμμή)

0.1088 0.5578 0.6855

0.6318 0.3134 0.2941

0.1265 0.1662 0.5306

0.1343 0.6225 0.8324

. . . . . . . . .

0.9138 0.8711 0.6537 (20η γραμμή)

To 3d νευρωνικό δίκτυο στο Pajek
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Δημιουργία αρχείου δικτύου με την Python
Η γλώσσα προγραμματισμού Python είναι πλέον η δεύτερη δημοφιλέστερη, μετά την Java (και στην ακαδημαϊκή κοινότητα, η πρώτη).
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Ή υποστήριξη της γλώσσας προγραμματισμού Python για χειρισμό γράφων και δικτύων

 Βιβλιοθήκη NetworkX
 Βιβλιοθήκη iGraph
 Και οι δύο διαθέτουν υποστήριξη για το Pajek

Η υλοποίηση της βιβλιοθήκης NetworkX για το Pajek, υποστηρίζει κατευθυνόμενους και μη-κατευθυνόμενους γράφους, 
συμπεριλαμβανομένων εκείνων με κόμβους που με βρόχους προς τον εαυτό τους, αλλά και εκείνων με παράλληλες ακμές.

Αριστοτέλειο Πανεπιστήμιο Θεσσαλονίκης |  Πρόγραμμα Μεταπτυχιακών Σπουδών στην Πληροφορική |  Προηγμένη Επεξεργασία Σήματος |  Δημήτριος Α. Ρούσης | www.MyThesis.orgMENU



Δημιουργία αρχείου δικτύου με το Excel2Pajek
Εφαρμογή που μετατρέπει αρχείο Excel σε αρχεία δικτύου .net.
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Βήματα

1. Δημιουργία ενός νέου αρχείου Excel
2. Εισαγωγή δεδομένων στις στήλες όπως στο 

υπόδειγμα της εικόνας (Info).
3. Εισαγωγή του xls στην εφαρμογή Excel2Pajek
4. Επιλογή για 1 ή 2-mode δίκτυο
5. Επιλογή directed ή undirected (μόνο για 1-mode)
6. Κλικ στο Create Pajek File
7. Άνοιγμα και απεικόνιση του αρχείου .net που 

προέκυψε, με το Pajek

Το αρχείο Excel θα πρέπει να έχει επέκταση xls (και όχι xlsx).

Φύλλο 1 (default όνομα στην Ελ. έκδοση…)
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Δημιουργία αρχείου δικτύου μέσω σχεσιακής ΒΔ
Δύο tables μπορούν να αντιπροσωπεύσουν ένα δίκτυο one-mode. Το ένα table, θα περιλαμβάνει τις κορυφές και το άλλο, τις συνδέσεις. 
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Το παράδειγμα αυτό μπορεί να βρεθεί στο βιβλίο: Exploratory Social Network Analysis with Pajek

Βήματα

1. Δημιουργία μιας νέας βάσης στην Access
2. Κατασκευή των πινάκων που θα παίξουν το ρόλο των κορυφών και των συνδέσεών τους (πίνακας γειτνίασης).
3. Σύνταξη ερωτημάτων για την  εξαγωγή δεδομένων με τη μορφή partition, vector κ.α.
4. Σχεδίαση φόρμας εισαγωγής δεδομένων
5. Εισαγωγή δεδομένων
6. Με δεξί κλικ στο ερώτημα “Export network to Pajek: arcs and edges” μπορούμε να το εξάγουμε σε αρχείο .net
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Άλλοι τρόποι δημιουργίας αρχείου δικτύου
Το Pajek μπορεί να επικοινωνήσει μέσω αρχείων κειμένου σχεδόν με οποιαδήποτε γλώσσα προγραμματισμού και συναφή εφαρμογή.
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Αρχεία άλλων εφαρμογών 

Ένας άλλος τρόπος δημιουργίας δικτύου με το Pajek,
είναι πρώτα αυτό να εξαχθεί από κάποια άλλη εφαρμογή, 
σε κάποιο αποδεκτό format, και στη συνέχεια να γίνει η 
εισαγωγή του μέσω του Pajek.

Εντολή εισαγωγής αρχείου:  File > Network > Read

Οι τύποι που υποστηρίζονται είναι:

 UCINET DL (gephi)
 Vega (Tomaz Pisanski project)
 GEDCOM (Genealogical Data)
 BS (Ball and Stick)
 MAC (Mac Molecule)
 MOL (MDL MOLfile)

Και η λίστα δεν τελειώνει εδώ…

http://www.pfeffer.at/txt2pajek

Η εφαρμογή TXT2Pajek.exe

Λαμβάνει ως είσοδο ένα αρχείο κειμένου (separator: tab, 
comma, semicolon, κ.α.) και επιστρέφει ένα αρχείο .net .
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Καθορισμός διάταξης δικτύου
Η κεντρική ιδέα ενός δικτύου συνήθως λαμβάνεται από τον άνθρωπο μέσω της απεικόνισής της διάταξής του.
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Αυτόματες ρουτίνες καθορισμού διάταξης δικτύου

Οι κυριότερες είναι:

 Ενέργειας
 Pivot MDS
 VOS Mapping

Μέσω των ρουτινών ενέργειας, το δίκτυο παρουσιάζεται ως
ένα φυσικό σύστημα (πχ: μια πρωτεΐνη) του οποίου ψάχνουμε
την βέλτιστη (ελάχιστη) ενεργειακή κατάσταση. Υπάρχουν δύο
αλγόριθμοι:

 Kamada – Kawai. Σχεδίαση σε ένα επίπεδο.
 Fruchterman – Reingold. Σχεδίαση 2D ή 3D.

Οι ρουτίνες Pivot MDS και VOS Mapping εφαρμόζονται σε πολύ
μεγάλα δίκτυα, των εκατό χιλιάδων κορυφών (Pivot MDS) και
άνω (VOS Mapping).

Χειροκίνητος καθορισμός διάταξης δικτύου

 Λειτουργεί συμπληρωματικά της αυτόματης, όταν κρίνονται
χρήσιμες ορισμένες διορθώσεις οι οποίες βελτιώνουν την
τελική απεικόνιση του δικτύου.

 Μπορεί όμως να χρησιμοποιηθεί και μόνο αυτή, ιδιαίτερα
όταν πρόκειται για πολύ απλά δίκτυα.

Χειρισμός

 Μπορούμε με το ποντίκι να μετακινούμε την κάθε κορυφή
κατά βούληση.

 Περιστροφή εικόνας 3d ή 2d δικτύου με τα πλήκτρα: x, X, y,
Y, z, Z (γράμμα = άξονας περιστροφής, κεφαλαία ή μικρά =
θετική ή αρνητική διεύθυνση, αντίστοιχα).

 Μπορεί να επιλεγεί οποιοσδήποτε άξονας περιστροφής
επιλέγοντας Spin > Normal. Στη συνέχεια, η περιστροφή
γύρω από τον επιλεγμένο άξονα γίνεται με τα πλήκτρα S και
s.
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Μορφές αρχείων εξόδου του Pajek
Οι απεικονίσεις των δικτύων που δημιουργούνται μέσω του Pajek μπορούν να εξαχθούν σε διάφορες μορφές αρχείων.
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Δισδιάστατη μορφή

Μενού: Export > 2D

Τρισδιάστατη μορφή

Μενού: Export > 3D
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2o μέρος



Τοπικές και ευρείες προβολές δικτύου
Οι τοπικές προβολές αφορούν συνδέσεις κορυφών μέσα στο ίδιο  cluster, ενώ οι ευρείες προβολές, μεταξύ διαφορετικών.
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Τοπική προβολή (local view)

Δημιουργείται επιλέγοντας ένα υποδίκτυο το οποίο εξάγεται
από κάποιο σύμπλεγμα κορυφών (πχ: σε μια τάξη μαθητών, οι
σχέσεις μεταξύ των αγοριών μόνο).

Ευρεία προβολή (global view)

Επιτυγχάνεται μέσω της συρρίκνωσης κορυφών που
βρίσκονται στο ίδιο σύμπλεγμα (cluster) σε μια νέα κορυφή.

Με αυτό τον τρόπο αναδεικνύονται οι σχέσεις που υπάρχουν
μεταξύ των clusters (πχ: σε μια τάξη μαθητών, οι σχέσεις
μεταξύ αγοριών και κοριτσιών, δηλαδή ο συνολικός αριθμός
των τόξων που ενώνουν τις δύο αυτές ομάδες).

Προβολή συνάφειας (contextual view)

Contextual = συνδυασμός Local & Global

Προβάλλονται οι σχέσεις που υπάρχουν μεταξύ των clusters
(πχ:΅για κάθε κορίτσι της τάξης, ποιος είναι ο συνολικώς
αριθμός των τόξων που συνδέεται με αγόρια)
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Βήματα εξαγωγής υποδικτύων
Προϋπόθεση: η ύπαρξη ενός αρχείου δικτύου (.net) κι ενός αρχείου partition (.clu) το οποίο έχει προκύψει από το δίκτυο αυτό.
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1

2

3

Από το συνολικό δίκτυο επιλέγουμε το υποδίκτυο που μας 
ενδιαφέρει.

Operations > Network + Partition > Extract > SubNetwork

Επιλογή υποδικτύου

Μενού

MANAGE

Επιλογή αριθμών και διαστημάτων των clusters

Παράδειγμα θα μπορούσε να αποτελεί και το υποδίκτυο που προκύπτει διαχωρίζοντας τις εισαγωγές και τις εξαγωγές μετάλλου, εντός μιας ηπείρου, από το
παγκόσμιο εμπόριο μετάλλου.
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Μείωση μεγέθους δικτύου
Η συρρίκνωση ενός δικτύου παρουσιάζει πολλά πλεονεκτήματα. Π.χ.: Η διευκόλυνση της οπτικής παρατήρησής και της ανάλυσής του.
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Παράδειγμα χρήσης θα μπορούσε να αποτελεί και η συρρίκνωση του δικτύου του παγκόσμιου εμπορίου μετάλλου, από το επίπεδο χωρών στο επίπεδο ηπείρων.

1. Συρρίκνωση

Operations > Network + Partition > Shrink Network

2. Αφαίρεση των γραμμών με χαμηλή τιμή

Μπορούμε να αφαιρέσουμε τις γραμμές αυτές 
επιλέγοντας:

Network > Create New Network > Transform > 
Remove > Lines with Value > lower

Και δίνοντας εν συνεχεία στο Pajek, το αντίστοιχο 
αριθμητικό κατώφλι που θα λειτουργεί ως κριτήριο.
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Εύρεση μονοπατιών (paths)
Μονοπάτι ή διαδρομή: Μία πεπερασμένη ή άπειρη ακολουθία διακριτών ακμών, που συνδέουν μια ακολουθία διακριτών κορυφών.
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Εύρεση συντομότερου μονοπατιού

1. Network > Create New Network > 
SubNetwork with Paths > One Shortest 
Path between Two Vertices

2. .

3. .

4. Identify vertices in source network? Νο
5. Layout > Energy > Kamada Kawai > Fix 

first and last
6. Options > Mark Vertices Using > Labels
7. Network > Create New Network > 

Transform > Arcs to Edges > All
8. Network > Create New Network > 

SubNetwork with Paths > All Shortest 
Paths between Two Vertices

K-neighbors

1. Network>Create Partition > k-Neighbors
> Output, αποστάσεις όλων των 
κορυφών από συγκεκριμένη κορυφή

2. Εισάγουμε την επιλεγμένη κορυφή και 
την απόσταση που θέλουμε να 
διερευνήσουμε (εισάγοντας το μηδέν 
υπολογίζονται όλες οι αποστάσεις).

3. Το αποτέλεσμα είναι ένα partition –
πίνακας (2xn), όπου για κάθε κορυφή 
παίρνουμε και την αντίστοιχη απόστασή 
της από την επιλεγμένη.

4. Network>Create Partition > k-Neighbors 
> Input, υπολογίζουμε τα βήματα που 
απαιτούνται προκειμένου από όλες τις 
άλλες κορυφές, να φτάσουμε στην 
επιλεγμένη

5. Network>Create Partition > k-Neighbors
> All, υπολογίζουμε τις αποστάσεις 
χωρίς να λαμβάνουμε υπόψη τις 
κατευθύνσεις των γραμμών

 Partition > Info,  ο αριθμός (που θα 
επιλέξουμε) των κοντινότερων (+) και 
των πιο απομακρυσμένων (-) κορυφών 
από την επιλεγμένη κορυφή.

Εύρεση διαμέτρου

1. Network > Create New Network > 
SubNetwork with Paths > Info on 
Diameter

2. Το Pajek επιστρέφει μόνο τις δύο πιο 
απομακρυσμένες κορυφές

3. Αν επιθυμούμε να έχουμε και το 
μονοπάτι ανάμεσά τους, θα πρέπει στο 
αποτέλεσμα, να εκτελέσουμε επιπλέον 
και την εντολή εύρεσης του 
συντομότερου μονοπατιού ανάμεσα σε 
αυτές τις δύο κορυφές.

Παράδειγμα shortest path

Αριστοτέλειο Πανεπιστήμιο Θεσσαλονίκης |  Πρόγραμμα Μεταπτυχιακών Σπουδών στην Πληροφορική |  Προηγμένη Επεξεργασία Σήματος |  Δημήτριος Α. Ρούσης | www.MyThesis.orgMENU



Ισχυρώς και Ασθενώς συνδεμένα στοιχεία
Το αποτέλεσμα του υπολογισμού είναι ένα partition στο οποίο οι κορυφές που ανήκουν στο ίδιο στοιχείο (συνιστώσα) έχουν τον ίδιο αριθμό. 
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Υπολογισμός στο Pajek

Network > Create Partition > Components > Weak

Network > Create Partition > Components > Strong

Ορισμοί

Ένας κατευθυνόμενος γράφος ονομάζεται ασθενώς 
συνδεδεμένος αν η αντικατάσταση όλων των κατευθυνόμενων 
ακμών του με μη κατευθυνόμενες ακμές, παράγει ένα 
συνδεδεμένο (μη-κατευθυνόμενο) γράφημα.

Ισχυρώς συνδεδεμένος ονομάζεται αν περιέχει ένα 
κατευθυνόμενο μονοπάτι από τον u στον v και ένα 
κατευθυνόμενο μονοπάτι V και U για κάθε ζεύγος κορυφών u, 
v.

http://en.wikipedia.org/wiki/Connectivity_(graph_theory)
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Αμφισυνδεδεμένα στοιχεία - κορυφές
Στη θεωρία γράφων, ένα αμφισυνδεδεμένο (2-connected) στοιχείο είναι ένας μέγιστος αμφισυνδεδεμένος υπό-γράφος.
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Υπολογισμός αμφιστοιχείων στο Pajek

Network > Create New Network > with Bi-Connected 
Components stored as Relation Numbers

Τρόπος αποθήκευσης αμφιστοιχείων

Τα αμφισυνδεδεμένα (biconnected  ή 2-connected) στοιχεία, 
αποθηκεύονται σε ιεραρχίες. Ένας κόμβος σε μια ιεραρχία 
αντιπροσωπεύει ένα αμφισυνδεδεμένο στοιχείο.

Σε μια ιεραρχία μπορούμε να πλοηγηθούμε όπως για 
παράδειγμα και στις δομές καταλόγων ενός παραθυρικού 
λειτουργικού συστήματος.

Εξαγωγή αμφιστοιχείων

Εξαγωγή ενός συγκεκριμένου αμφιστοιχείου (ή αμφικορυφής, 
ή αμφικόμβου): Hierarchy > Extract Cluster, δίνοντας στη 
συνέχεια τον αριθμό του κόμβου της ιεραρχίας που μας 
ενδιαφέρει.

Για την εξαγωγή του υποδικτύου που προκύπτει από την πιο 
πάνω ενέργεια: Operations > Network + Cluster > Extract 
SubNetwork.

http://en.wikipedia.org/wiki/Biconnected_component

Παράδειγμα 

Οι κορυφές με τα 2 χρώματα ονομάζονται αμφισυνδεδεμένες 
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Άκυκλα δίκτυα
Παραδείγματα άκυκλων δικτύων: Γενεαλογίες, δίκτυα παραπομπών (citations), αλγόριθμοι εύρεσης μονοπατιών, κ.α.
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Δομή άκυκλων δικτύων

Σε ένα άκυκλο δίκτυο υπάρχουν οι πρώτες κορυφές
(επίπεδο 1) στις οποίες δεν φθάνουν γραμμές, οι
ενδιάμεσες, και οι τελικές (επίπεδο n) από τις οποίες
δε ξεκινά καμία γραμμή σύνδεσης.

Επομένως κάθε άκυκλο δίκτυο έχει ένα βάθος, το
μέγεθος του οποίου εξαρτάται από το σύνολο των
επιπέδων των κορυφών του.

Υπολογισμός βάθους άκυκλου δικτύου στο Pajek

Network > Acyclic Network > Depth Partition > Acyclic

http://en.wikipedia.org/wiki/Acyclic_graph

Παραδείγματα: Κατευθυνόμενο άκυκλο δίκτυο (a), Δέντρο (b), Πολύδεντρο (c)

(c)

(b)

(a)
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Δείκτες κεντρικότητας (centrality indicators)
Οι δείκτες κεντρικότητας χρησιμοποιούνται για τον εντοπισμό των πιο σημαντικών κορυφών σε ένα δίκτυο.

27

Pajek 4.03

Κυριότεροι υπολογισμοί κεντρικότητας στο Pajek

Network > Create Vector > Centrallity > Betweenness

Network > Create Vector > Centrallity > Closeness

Network > Create Vector > Centrallity > Degree

http://en.wikipedia.org/wiki/Centrality

Θεωρία

Δείκτες κεντρικότητας

A. Ενδιαμεσότητα – Δείχνει 
το πόσο κεντρικός είναι 
ένας κόμβος του δικτύου

B. Πυκνότητα - Απόσταση 
μεταξύ όλων των ζευγών 
των κόμβων, που ορίζεται 
από το μήκος των shortest 
paths τους

C. Ιδιοδιάνυσμα - Μέτρο της 
επίδρασης ενός κόμβου σε 
ένα δίκτυο

D. Βαθμός – Ο προσπίπτων 
αριθμός συνδέσεων σε ένα 
κόμβο

E. Αρμονική – Συνδέσεις 
κόμβων προς κόμβο, από 
απόσταση 1 έως n

F. Leo Katz
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Τριαδική απογραφή (triadic census)
Ονομάζεται η εύρεση όλων των μοτίβων (patterns ή cliques) τριάδων ενός κατευθυνόμενου γράφου – δικτύου.
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Υπολογισμός τριαδικής απογραφής στο Pajek

Network > Info > Triadic Census

Όλα τα πιθανά τριαδικά μοτίβα (αριθμοί ακολουθιών Pajek)

http://vlado.fmf.uni-

lj.si/pub/networks/doc/triads/triads.pdf
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Πυρήνες (cores)
Πυρήνας: Μετασχηματισμός ενός αρχικού δικτύου σε ένα άλλο, που διατηρεί τις σχέσεις μεταξύ των στοιχείων του πρώτου (ομομορφικός).
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Παραδείγματα πυρήνων

o Πλήρεις γράφοι
o Κύκλοι περιττού μήκους
o Κύκλοι άρτιου μήκους (ανά δύο)

Βήματα υπολογισμού πυρήνων στο Pajek

1. Network > Create Partition > K-Core
2. Input, Output ή All

Αποτέλεσμα: Ένα partition για κάθε κορυφή του οποίου δίνεται
και ο αριθμός του πυρήνα που ανήκει.

Στις περισσότερες περιπτώσεις ενδιαφερόμαστε μόνο για τον
μεγαλύτερο πυρήνα (ή πυρήνες):

3. Operations > Network + Partition > Extract SubNetwork
4. Εισάγουμε τον ίδιο αριθμό (του μεγαλύτερου πυρήνα) δύο

φορές

http://en.wikipedia.org/wiki/Core_(graph_theory)

Θεωρία: k-πυρήνας (k-core)

Ένα υποσύνολο κορυφών ονομάζεται k-πυρήνας αν κάθε κορυφή του
υποσυνόλου είναι συνδεδεμένη με τουλάχιστον k κορυφές του
υποσυνόλου αυτού. Στην εικόνα διακρίνονται πυρήνες διαφόρων
μεγεθών (0, 1, 2 και 3):
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Κλίκες (cliques)
Η κλίκα είναι ένας ειδικός τύπος πυρήνα
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http://wikipedia.org/wiki/Clique_(graph_theory)

Αναζήτηση κλικών

 Είναι επεξεργαστικά πιο απαιτητική σε σχέση με την
αναζήτηση πυρήνων

 Προτιμάται η αναζήτηση κλικών μεγέθους 3 ή 4 σε
μικρά δίκτυα

Αναζητώντας κλίκες μεγέθους 3 (3-cliques), μπορούμε
να βρούμε 16 διαφορετικούς συνδυασμούς όπως
είδαμε ήδη και προηγουμένως (τριαδική απογραφή).

Αν όμως θέλουμε να βρούμε όλες τις εμφανίσεις των
κλικών μεγέθους 3, δηλαδή και τύπους τριάδων που
εμφανίζονται περισσότερες από μία φορές ?

Τότε κάνουμε χρήση μιας γενικότερης διαδικασίας,
κατά την οποία γίνεται αναζήτηση τμημάτων ή αλλιώς
προτύπων (Fragments), στο δίκτυο.

Θεωρία

Ένα υποσύνολο ενός δικτύου ονομάζεται κλίκα, εάν καθεμιά
κορυφή του υποσυνόλου αυτού συνδέεται με την καθεμιά
από τις άλλες κορυφές του.

23 × 1-vertex cliques (οι κορυφές)
42 × 2-vertex cliques (οι γραμμές σύνδεσης)
19 × 3-vertex cliques (τα ανοικτά και σκούρα μπλε τρίγωνα)
2 × 4-vertex cliques (μόνο οι σκούρες μπλε περιοχές)
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Αναζήτηση προτύπων (fragments)
Είναι η διαδικασία κατά την οποία γίνεται μια προσπάθεια εντοπισμού μικρότερων δικτύων σε ένα δίκτυο (πχ: αναζήτηση των 3-cliques)

31

Pajek 4.03

Αναζήτηση προτύπων στο Pajek

1. Σχεδιάζουμε το πρότυπο οι ίδιοι, ως ένα νέο,
ανεξάρτητο και πλήρες κατευθυνόμενο δίκτυο:

Network > Create New Network > Complete
Network > Directed

2. Ορίζουμε το νέο μικρό δίκτυο ως fragment,
επιλέγοντάς το ώστε να είναι το πρώτο δίκτυο στην
αντίστοιχη dropdown λίστα. Φροντίζουμε το αρχικό
δίκτυο να είναι το δεύτερο

3. Αν υπάρχουν γραμμές θα πρέπει να μετατραπούν σε
αμφίδρομα τόξα, επειδή ο αλγόριθμος αναζήτησης
κάνει διάκριση μεταξύ edges και bidirected arcs:

Network > Create New Network > Transform >
Edges > Arcs

4. Πραγματοποιούμε την αναζήτηση:

Networks > Fragment (First in Second) (> Find)

Αποτελέσματα αναζήτησης

 Ένα υποδίκτυο το οποίο περιέχει μόνο όλα τα
fragments που είναι ίδια με το δοσμένο κριτήριο
αναζήτησης.

 Ένα partition με τιμές από μηδέν και άνω. Η τιμή
μηδέν σημαίνει ότι η αντίστοιχη κορυφή δεν ανήκει
σε κάποιο fragment. Μία τιμή a, σημαίνει ότι η
αντίστοιχη κορυφή ανήκει σε a fragments.

 Μια ιεραρχία με όλα τα fragments

Αριστοτέλειο Πανεπιστήμιο Θεσσαλονίκης |  Πρόγραμμα Μεταπτυχιακών Σπουδών στην Πληροφορική |  Προηγμένη Επεξεργασία Σήματος |  Δημήτριος Α. Ρούσης | www.MyThesis.orgMENU



Παράδειγμα

Μέθοδοι εντοπισμού κοινοτήτων (communities)
Οι δομές κοινοτήτων είναι πυκνά clusters όπου στο εσωτερικό τους υπάρχουν περισσότερες συνδέσεις απ’ ότι στο εξωτερικό τους
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Μέθοδοι εντοπισμού δομών κοινοτήτων στο Pajek

Το Pajek διαθέτει δύο μεθόδους εντοπισμού δομών 
κοινοτήτων:

 Μέθοδος Louvain
 Μέθοδος VOS clustering

http://en.wikipedia.org/wiki/Community_structure

http://mrvar.fdv.uni-

lj.si/pajek/community/LouvainVOS.htm

http://mrvar.fdv.uni-

lj.si/pajek/community/CommunityDrawExample.htm

Αριστοτέλειο Πανεπιστήμιο Θεσσαλονίκης |  Πρόγραμμα Μεταπτυχιακών Σπουδών στην Πληροφορική |  Προηγμένη Επεξεργασία Σήματος |  Δημήτριος Α. Ρούσης | www.MyThesis.orgMENU

http://en.wikipedia.org/wiki/Community_structure
http://mrvar.fdv.uni-lj.si/pajek/community/LouvainVOS.htm
http://mrvar.fdv.uni-lj.si/pajek/community/CommunityDrawExample.htm


Δίκτυα δύο τύπων (2-mode)
Ένα 2-mode δίκτυο, αποτελείται από δύο είδη μονάδων - υποσυνόλων (πχ: υπάλληλοι και εταιρείες), τα οποία συσχετίζονται με συνδέσεις.
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Δημιουργία 2-mode δικτύου στο Pajek

Network > 2-Mode Network > Partition into 2 Modes

Όπου στις κορυφές του πρώτου υποσυνόλου (υπάλληλοι) δίνεται
ο αριθμός 1, και σε εκείνες του δευτέρου (εταιρείες), δίνεται ο
αριθμός 2.

Βήματα μετασχηματισμού δικτύου 2-mode σε 1-mode

1. Εξάγουμε το πρώτο υποσύνολο των κορυφών:

Network > 2-Mode Network > 2-Mode to 1-Mode > Rows

2. Εξάγουμε το δεύτερο υποσύνολο:

Network > 2-Mode Network > 2-Mode to 1-Mode > Columns

Επίσης μπορούμε να δημιουργήσουμε δίκτυο με βρόχους ή χωρίς:
Network > 2-Mode Network > 2-Mode to 1-Mode > Include Loops

Για τη δημιουργία δικτύων με βάρη (πχ: αριθμός υπαλλήλων της
ίδια εταιρείας), ή δικτύων με πολλαπλές γραμμές:
Network > 2-Mode Network > 2-Mode to 1-Mode > Multiple Lines

http://mrvar.fdv.uni-lj.si/sola/info4/uvod/twomode.pdf

Αριστοτέλειο Πανεπιστήμιο Θεσσαλονίκης |  Πρόγραμμα Μεταπτυχιακών Σπουδών στην Πληροφορική |  Προηγμένη Επεξεργασία Σήματος |  Δημήτριος Α. Ρούσης | www.MyThesis.orgMENU

http://mrvar.fdv.uni-lj.si/sola/info4/uvod/twomode.pdf


Απεικόνιση δικτύου με βάρη (αξίες, κόστη κλπ.)
Ένα σταθμισμένο δίκτυο αντιστοιχίζει μια ετικέτα (βάρος) με κάθε κόμβο στο δίκτυο αυτό.
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Βήματα απεικόνισης στο Pajek

1. Αποθηκεύουμε πρώτα τις αξίες αυτές σε ένα αρχείο vector:
Network > Create Vector > Get Loops

2. Χρησιμοποιούμε το vector αυτό για να καθορίσουμε τα μεγέθη των 
κορυφών:

Draw > Network + Vector

Αφού δημιουργηθεί δίκτυο με τις αξιολογημένες γραμμές, μπορούμε να 
το απεικονίσουμε με πολλούς τρόπους:

i. Απεικόνιση πλήρους δικτύου:
a. απεικονίζουμε το δίκτυο χρησιμοποιώντας την μέθοδο 

Energy, έχοντας επιλέξει Options > Values of Lines > 
Similarities (για να εμφανιστούν πιο κοντά οι γραμμές με τις 
υψηλότερες τιμές)

b. Οι αξίες των μπορούν να αναπαρασταθούν με διαφορετικά 
πάχη γραμμής (Options > Lines > Different Widths) ή/και με 
χρήση διαβαθμίσεων του γκρι (Options > Lines > Grey-Scale).

c. Αφού εξάγουμε την εικόνα σε μορφή SVG, μπορούμε να 
προσθέσουμε γραμμές ανάλογα με την αξία τους Export > 
SVG > Line-Values > Nested Classes

ii. Απεικόνιση του πιο σημαντικού μέρους του δικτύου: Εμφανίζονται 
μόνο οι γραμμές με αξία πάνω από ένα κατώφλι.

http://en.wikipedia.org/wiki/Glossary_of_graph_theor

y#Weighted_graphs_and_networks

Θεωρία: Βάρη, ή αξίες, ή κόστη, ή σταθμίσεις

Τα βάρη είναι συνήθως πραγματικοί αριθμοί. Μπορεί όμως να
περιορίζονται σε ρητούς αριθμούς ή σε ακεραίους. Ορισμένοι
αλγόριθμοι απαιτούν περαιτέρω περιορισμούς σχετικά με τα βάρη.
Για παράδειγμα, ο αλγόριθμος του Dijkstra δουλεύει σωστά μόνο
για θετικά βάρη. Το βάρος ενός μονοπατιού ή το βάρος ενός
δέντρου σε ένα σταθμισμένο δίκτυο, είναι το άθροισμα των βαρών
των γραμμών (συνδέσεων) που το απαρτίζουν.

Αριστοτέλειο Πανεπιστήμιο Θεσσαλονίκης |  Πρόγραμμα Μεταπτυχιακών Σπουδών στην Πληροφορική |  Προηγμένη Επεξεργασία Σήματος |  Δημήτριος Α. Ρούσης | www.MyThesis.orgMENU

http://en.wikipedia.org/wiki/Glossary_of_graph_theory#Weighted_graphs_and_networks


Νησίδες (islands)
Σε ένα δίκτυο όπου δίνονται ορισμένες ιδιότητες (τιμές) των κόμβων ή των γραμμών, μπορούμε να βρούμε νησίδες
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Υπολογισμός νησίδων στο Pajek

Οι νησίδες, ονομάζονται νησίδες κόμβων αν δίνονται οι
αξίες των κόμβων, και νησίδες γραμμών, αν δίνονται οι
αξίες των γραμμών.

Οι νησίδες μοιάζουν με τις κλίκες, δηλαδή, μπορούμε να
τις εντοπίσουμε σε clusters κόμβων με αξίες σύνδεσης
μεγαλύτερες εντός του cluster και μικρότερες εκτός.

Για τον εντοπισμό τους θα πρέπει επίσης να επιλέξουμε
το μικρότερο και το μεγαλύτερο επιτρεπόμενο μέγεθος
της νησίδας.

Στο Pajek οι γραμμές των νησίδων υπολογίζονται:

Network > Create Partition > Islands > Lines Weights

http://vlado.fmf.uni-lj.si/pub/networks/doc/sunbelt/islands.pdf

Αριστοτέλειο Πανεπιστήμιο Θεσσαλονίκης |  Πρόγραμμα Μεταπτυχιακών Σπουδών στην Πληροφορική |  Προηγμένη Επεξεργασία Σήματος |  Δημήτριος Α. Ρούσης | www.MyThesis.orgMENU
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Ιεραρχικό clustering
Μέθοδος ανάλυσης συστάδων που επιδιώκει να οικοδομήσει μια ιεραρχία των συστάδων
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Βήματα ιεραρχικού clustering στο Pajek

1. Δημιουργία πλήρως συνδεδεμένου cluster προκειμένου οι
ανομοιότητες να υπολογιστούν για όλες τις μονάδες

Cluster > Create Complete Cluster

2. Υπολογισμός του dissimilarity matrix (πίνακας ανομοιοτήτων)
Operations > Network + Cluster > Dissimilarity > Network
Based

 Επιλέγουμε:

i. d1/All αν θέλουμε να θεωρήσουμε το δίκτυο ως ένα
δυαδικό πίνακα

ii. Corrected Euclidian ή Corrected Manhattan, απόσταση
για δίκτυα με βάρη - αξίες.

3. Μας ζητείται να ονομάσουμε το αρχείο EPS που θα δημιουργηθεί
στο οποίο θα αποθηκευτεί το δενδρόγραμμα που θα προκύψει

4. Επιλέγουμε ΟΚ προκειμένου να πραγματοποιηθεί το Ιεραρχικό
clustering με βάση τον dissimilarity matrix που υπολογίστηκε.

http://en.wikipedia.org/wiki/Hierarchical_clustering

Τα αποτελέσματα του ιεραρχικού clustering

 Ο dissimilarity matrix
 Η εικόνα EPS το δενδρογράμματος (άνοιγμα με GSview)
 Ένα αρχείο ανακατέματος .per (permutation) σύμφωνα με το 

δενδρόγραμμα το οποίο μπορεί να χρησιμοποιηθεί για την 
απεικόνιση του πίνακα αναδιάταξης (reordered matrix) στο EPS 
(File > Network > Export Matrix to EPS > Using Permutation).

 Ιεραρχία που αναπαριστά το ιεραρχικό clustering

Υπόδειγμα: Simple Hierarchical Clustering

Αριστοτέλειο Πανεπιστήμιο Θεσσαλονίκης |  Πρόγραμμα Μεταπτυχιακών Σπουδών στην Πληροφορική |  Προηγμένη Επεξεργασία Σήματος |  Δημήτριος Α. Ρούσης | www.MyThesis.orgMENU

http://en.wikipedia.org/wiki/Hierarchical_clustering


Μοντελοποίηση σε μπλοκ (Blockmodeling)
Μείωση ενός μεγάλου, και ενδεχομένως ασυνάρτητου δικτύου, σε μια μικρότερη πιο κατανοητή δομή που μπορεί να ερμηνευθεί ευκολότερα.
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Βήματα μοντελοποίησης σε μπλοκ, στο Pajek

1. Επιλογή τρόπου μοντελοποίησης:

a. Ξεκινώντας με τυχαίο partition σε δοσμένο αριθμό
clusters Network > Create Partition > Blockmodeling* >
Random Start

b. Βελτιστοποιώντας το δοσμένο partition (πχ: partition
που προέκυψε από ιεραρχικό clustering) Network >
Create Partition > Blockmodeling* > Optimize Partition

2. Αφού επιλέξουμε τον τρόπο που θα πραγματοποιηθεί το
blockmodeling, επιλέγουμε:

i. Τον τύπο ισοδυναμίας (typeof equivalence – Structural
ή Regular). Μπορούμε επίσης να καθορίσουμε τους
δικούς μας τύπους blocks επιλέγοντας 3-Define.

ii. Τον αριθμό των επαναλήψεων
iii. Τον αριθμό των clusters

3. Run

http://vlado.fmf.uni-lj.si/pub/networks/doc/KN/Course4.pdf

Βήματα μοντελοποίησης σε μπλοκ, στο Pajek

Όλα τα διαφορετικά partitions με την χαμηλότερη τιμή της συνάρτησης
του κριτηρίου (ένα ή περισσότερα partitions).

Αριστοτέλειο Πανεπιστήμιο Θεσσαλονίκης |  Πρόγραμμα Μεταπτυχιακών Σπουδών στην Πληροφορική |  Προηγμένη Επεξεργασία Σήματος |  Δημήτριος Α. Ρούσης | www.MyThesis.orgMENU
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Χρονικώς μεταβαλλόμενα δίκτυα (temporal)
Στα χρονικώς μεταβαλλόμενα (ή δυναμικά) δίκτυα, οι κόμβοι και οι γραμμές δεν είναι απαραιτήτως παρούσες σε κάθε στιγμή.

38

Pajek 4.03

Δημιουργία δυναμικού δικτύου με το Pajek

Στο αρχείο εισόδου που δημιουργούμε για το Pajek μπορούμε για
ένα δυναμικό δίκτυο να χρησιμοποιούμε τις παρακάτω μορφές
χρονικής υπόστασης:

 ti – μια μόνο χρονική στιγμή
 ti–tj – ένα χρονικό διάστημα
 ti-* – από μία χρονική στιγμή και μετά

Έστω δυναμικό δίκτυο με κορυφές a, b, c οι οποίες εμφανίζονται:

 a – Σε δύο χρονικά διαστήματα. Από το 5 δευτερόλεπτο έως το
10 και από το 12 έως το 14.

 b – Από το διάστημα 1 έως 3 και έπειτα μόνο στο 7
 c – Από το 4 και μετά

Και γραμμές μεταξύ των a-b, και των a-c οι οποίες εμφανίζονται:

 a-b – Μόνο τη χρονική στιγμή 7
 a-c – Στο χρονικό διάστημα 6 έως 8

Αφού ανοίξουμε το αρχείο .net μέσω του Pajek, επιλέγουμε
Network > Temporal Network > Generate in Time

http://vlado.fmf.uni-

lj.si/pub/networks/doc/seminar/SFI-SAS04tn.pdf

Το Pajek υποστηρίζει και ένα σύνολο χρονικών
συμβάντων για μεταβαλλόμενα (ή δυναμικά)
δίκτυα πραγματικού χρόνου:

*Vertices 3
1 "a" [5-10,12-14]
2 "b" [1-3,7]
3 "c" [4-*]
*Edges
1 2 1 [7]
1 3 1 [6-8]

Το αρχείο δικτύου
.net θα έπρεπε να
συνταχθεί ως εξής:

Αριστοτέλειο Πανεπιστήμιο Θεσσαλονίκης |  Πρόγραμμα Μεταπτυχιακών Σπουδών στην Πληροφορική |  Προηγμένη Επεξεργασία Σήματος |  Δημήτριος Α. Ρούσης | www.MyThesis.orgMENU

http://vlado.fmf.uni-lj.si/pub/networks/doc/seminar/SFI-SAS04tn.pdf


Συνδεσιμότητα μικρών κύκλων
Δύο κορυφές πρέπει να συνδέονται από μικρούς κύκλους συνδέσεων, όπου οι δύο γειτονικοί θα πρέπει να έχουν τουλάχιστον μια κοινή κορυφή.
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Δημιουργία κύκλων στο Pajek

Δίκτυο μικρών κύκλων που οι δακτύλιοί τους να είναι
τριγωνικοί (3-Rings):

Network > Create New Network > with Ring Counts
stored as Line Values > 3-Rings

Τετραγωνικοί (4-Rings):

Network > Create New Network > with Ring Counts
stored as Line Values > 4-Rings

Οι δακτύλιοι μπορεί να είναι κατευθυνόμενοι ή μη
κατευθυνόμενοι.

http://arxiv.org/pdf/cs/0308011.pdf
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Εξαγωγή δεδομένων
Υπάρχει δυνατότητα εξαγωγής δεδομένων σε διάφορους τύπους αρχείων για την περαιτέρω ανάλυσή τους από άλλα λογισμικά.
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Εξαγωγή στην R για στατιστική ανάλυση

Για να συνεργαστεί το Pajek με την R θα πρέπει να εντοπιστεί το
εκτελέσιμο της R που δημιουργεί τα γραφικά:
Tools > R > Locate R
(εντοπισμός αρχείου C:\Program Files\...\bin\Rgui.exe ή Rterm.exe)

Αφού γίνει αυτό, τα δεδομένα μπορούν να σταλούν
Tools > R > Send to R.

Εξαγωγή στο SPSS για στατιστική ανάλυση

Eντοπίζουμε το αρχείο runsyntx.exe που βρίσκεται συνήθως στον
κατάλογο C:\Program Files\SPSS:
Tools > SPSS > Locate SPSS

Στη συνέχεια μπορούμε να στείλουμε δίκτυα, partitions και vectors,
επιλέγοντας: Tools > SPSS > Send to SPSS

Εξαγωγή σε αρχείο χωρισμένο με tabs

Tools > Export to Tab Delimited File

Για άνοιγμα από στατιστικό πακέτο (πχ: Stata), ή από το Excel.
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3o μέρος
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Σενάριο χρήσης με πραγματικά δεδομένα (1/7)
Το παγκόσμιο εμπόριο μετάλλου. Τα τόξα του δικτύου αντιπροσωπεύουν τις εισαγωγές μετάλλου που κάνει μία χώρα από μία άλλη.

Αναλυτικά βήματα υπολογισμών - απεικόνισης

Αφού εισάγουμε το αρχείο του δικτύου στο Pajek
(File>Network>Read>Imports_manufactures.net), επιλέγουμε
Draw>Network και προκύπτει ο γράφος της διπλανής εικόνας:

Το μέγεθος των κόκκινων κουκίδων εισάγεται από εμάς μέσω
του μενού, επιλέγοντας Options>Size>Of Vertices. Τα βάρη των
συνδέσεων ενεργοποιούνται και απενεργοποιούνται μέσω του
Options>Lines>Mark Lines.

Εύκολα παρατηρούμε από την εικόνα ότι σχηματίζονται τρεις
νοητοί «ομόκεντροι» κύκλοι. Τρεις ομάδες χωρών. Η κεντρική
ομάδα αποτελεί τον πυρήνα του εμπορίου του μετάλλου, και
καθώς κινούμαστε προς τα έξω, συναντάμε τις χώρες που
παίζουν δευτερεύων και τριτεύων ρόλο, αντιστοίχως. Αυτό είναι
το πρώτο και το ευκολότερο συμπέρασμα που μπορούμε να
βγάλουμε.

Είναι προφανές ότι ο αριθμός των γραμμών είναι αρκετά
μεγάλος και δυσχεραίνει την περεταίρω οπτική ανάλυση του
δικτύου μας. Για το λόγο αυτό θα πρέπει να επιλεγεί κάποιο
κριτήριο - εργαλείο απλοποίησης ή σήμανσης που θα μας
επιτρέψει να βγάλουμε επιπλέον συμπεράσματα.
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Σενάριο χρήσης με πραγματικά δεδομένα (2/7)
Το παγκόσμιο εμπόριο μετάλλου. Τα τόξα του δικτύου αντιπροσωπεύουν τις εισαγωγές μετάλλου που κάνει μία χώρα από μία άλλη.

Ένας τρόπος για να επιτευχθεί κάτι τέτοιο, είναι η διαμέριση
(partitioning) του δικτύου των χωρών σε ηπείρους. Αυτό
επιτυγχάνεται μέσω της εισαγωγής του αντίστοιχου αρχείου
(File > Partition > Read > Continent.clu).

Μετά την ολοκλήρωση της εισαγωγής, θα πρέπει να
επιβεβαιώσουμε οπτικά ότι το αρχείο διαμέρισης .clu έχει τον
ίδιο αριθμό κόμβων με το αρχείο του δικτύου .net (που στην
περίπτωσή μας είναι 80):

Κάνοντας κλικ στο εικονίδιο του μεγεθυντικού φακού (View/Edit
Partition) κάτω από το κουμπί Partition, μπορούμε να δούμε την
διαμέριση βάσει των ηπείρων.

Η στήλη Vertex συμβολίζει τις κορυφές του δικτύου και παίρνει τιμές 1 – 80 (αριθμός συμμετεχουσών χωρών). Η στήλη με το όνομα Val παίρνει τιμές 1
– 6 και συμβολίζει τις 6 από τις 7 ηπείρους, μιας και δεν υπάρχουν χώρες που να αντιπροσωπεύουν την έβδομη (πιθανότατα επειδή δεν συμμετέχουν
στο δίκτυο εισαγωγών μετάλλου). Η Ελλάδα ανήκει στην Ευρώπη, επομένως εύκολα βγαίνει το συμπέρασμα ότι όποια χώρα (Label) έχει την τιμή (Val)
3, ανήκει στην Ευρώπη.
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Σενάριο χρήσης με πραγματικά δεδομένα (3/7)
Το παγκόσμιο εμπόριο μετάλλου. Τα τόξα του δικτύου αντιπροσωπεύουν τις εισαγωγές μετάλλου που κάνει μία χώρα από μία άλλη.

Επιλέγοντας Draw > Network + First Partition, παίρνουμε μία
λίγο πιο κατατοπιστική απεικόνιση του δικτύου, μιας και το
Pajek εφαρμόζει αυτόματα διαφορετικό χρώμα για καθεμιά από
τις 6 ηπείρους:

Η εμφάνιση του αριθμού της ηπείρου εφαρμόζεται επιλέγοντας
Options > Mark Vertices Using > Partition Clusters.

Με μια σύντομη παρατήρηση συμπεραίνουμε ότι κάποιες χώρες
της Ευρώπης (κόκκινο χρώμα) ανήκουν στον πυρήνα, ενώ
κάποιες άλλες όχι. Οι χώρες εκτός πυρήνα είναι σίγουρα
κατώτερες οικονομικά από τις χώρες εντός.

Παρ’ όλα αυτά, το δίκτυό μας συνεχίζει να περιέχει αρκετή
ακόμα πληροφορία που δυσχεραίνει την παρατήρησή του. Μία
από τις πρώτες επεμβάσεις που μπορούν να γίνουν, είναι η
συρρίκνωση του δικτύου. Αυτό μπορεί να γίνει αφού πρώτα
θέσουμε ένα λογικό στόχο, όπως είναι για παράδειγμα η
αναπαράσταση της συσχέτισης στο εμπόριο μετάλλου μεταξύ
των 6 ηπείρων που συμμετέχουν.
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Σενάριο χρήσης με πραγματικά δεδομένα (4/7)
Το παγκόσμιο εμπόριο μετάλλου. Τα τόξα του δικτύου αντιπροσωπεύουν τις εισαγωγές μετάλλου που κάνει μία χώρα από μία άλλη.

Επιλέγοντας από το κεντρικό μενού του Pajek, Operations >
Network + Partition > Shrink Network, εμφανίζεται το παρακάτω
παράθυρο διαλόγου, στο οποίο ζητείται να εισαχθεί ο ελάχιστος
αριθμός συνδέσεων μεταξύ των clusters του partition και ο
αριθμός του cluster που δεν επιθυμούμε να συρρικνωθεί:

Ως αποτέλεσμα παίρνουμε κάτι πολύ πιο ευανάγνωστο αλλά με
ορισμένα σημεία στα οποία απαιτείται από εμάς χειροκίνητη
διόρθωση:
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Σενάριο χρήσης με πραγματικά δεδομένα (5/7)
Το παγκόσμιο εμπόριο μετάλλου. Τα τόξα του δικτύου αντιπροσωπεύουν τις εισαγωγές μετάλλου που κάνει μία χώρα από μία άλλη.

Πρέπει οι κορυφές του νέου δικτύου να αποτελούνται μόνο από
ονόματα ηπείρων. Επομένως θα πρέπει να γίνει ανάλογη
επεξεργασία στη νέα αυτή διαμέριση που έχει προκύψει μετά τη
συρρίκνωση:

Η αλλαγή των ονομάτων γίνεται στα πεδία της στήλης Label:

Και το νέο δίκτυο αποτελείται πλέον, μόνο από τα ονόματα των 6
ηπείρων:

Αν και ο παραπάνω γράφος είναι αρκετά απλός, είναι λίγο
δύσκολο κάποιος να μπορέσει να καταλάβει αν είναι πλήρης. Η
χρήση ενός πίνακα γειτνίασης (adjacency matrix) μπορεί να
προσφέρει μια καλύτερη εικόνα.
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Σενάριο χρήσης με πραγματικά δεδομένα (6/7)
Το παγκόσμιο εμπόριο μετάλλου. Τα τόξα του δικτύου αντιπροσωπεύουν τις εισαγωγές μετάλλου που κάνει μία χώρα από μία άλλη.

Μέσα από το κεντρικό μενού του Pajek επιλέγουμε File >
Network > Export as Matrix to EPS > Using Partition > Structural.
Στα παράθυρα διαλόγου που θα προκύψουν αφήνουμε τις
προεπιλεγμένες τιμές και σώζουμε το αρχείο που περιλαμβάνει
τον πίνακα γειτνίασης στο αρχείο adjacency_matrix.eps.

Στη συνέχεια, αν στο σύστημά μας υπάρχει εγκατεστημένο το
απαιτούμενο λογισμικό , μπορούμε να προβάλουμε τον πίνακα
γειτνίασης κάνοντας διπλό κλικ στο αντίστοιχο αρχείο:

Κάνοντας κλικ στο εικονίδιο με τον μεγεθυντικό φακό που
βρίσκεται κάτω από το κουμπί Vectors, εμφανίζεται ο πίνακας με
τις τιμές που αφορούν την ενδιαμεσότητα της κάθε Ηπείρου:

Είναι προφανές με την πρώτη ματιά, ότι ο γράφος μας δεν είναι
πλήρως συνδεδεμένος και ότι ο παραπάνω πίνακας δεν είναι
συμμετρικός. Δηλαδή, το εμπόριο μετάλλου δεν
πραγματοποιείται από, και προς, όλες τις ηπείρους. Για
παράδειγμα, η Αυστραλία δε συναλλάσσεται με την Αφρική.

Σε αυτό το σημείο έχει επίσης νόημα, να υπολογίσουμε το
μέγεθος της ενδιαμεσότητας (betweenness ) δημιουργώντας ένα
διάνυσμα μέσω του Pajek. Από το κεντρικό μενού επιλέγουμε
Network > Create Vector > Centrality > Betweenness. Το νέο
διάνυσμα εμφανίζεται στο αντίστοιχο πεδίο:
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Σενάριο χρήσης με πραγματικά δεδομένα (7/7)
Το παγκόσμιο εμπόριο μετάλλου. Τα τόξα του δικτύου αντιπροσωπεύουν τις εισαγωγές μετάλλου που κάνει μία χώρα από μία άλλη.

Όπως ήταν ίσως αναμενόμενο, η ήπειρος της Ασίας παρουσιάζει
τη μεγαλύτερη ενδιαμεσότητα. Αυτό σημαίνει ότι στο παγκόσμιο
εμπόριο του μετάλλου (το έτος 1994) οι ασιατικές χώρες παίζουν
κομβικό ρόλο και έχουν το μεγαλύτερο μερίδιο των
συναλλαγών.

Αυτό είναι ακόμα πιο προφανές αν το διάνυσμα παρουσιαστεί
γραφικά, επιλέγοντας Draw > Network + First Vector:
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Βιοϋπολογισμός του συντομότερου μονοπατιού
Ο ευκαρυωτικός οργανισμός Physarum polycephalum, ανήκει στα πρώτιστα και μπορεί να «υπολογίσει» το συντομότερο μονοπάτι σε ένα γράφο.
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Βήματα βιοϋπολογισμού

Ο συγκεκριμένος οργανισμός δε διαθέτει εγκέφαλο, ούτε κάποιου
είδους νευρικό σύστημα. Όμως, παρ’ όλα αυτά, είναι σε θέση να
λαμβάνει αρκετά σύνθετες «αποφάσεις» προκειμένου να
προσεγγίσει την τροφή του.

Παράδειγμα με λαβύρινθο:

a. Αρχικά επεκτείνει τους δενδρίτες , του σε όλους τους
διαδρόμους χαρτογραφώντας έτσι ολόκληρο το λαβύρινθο (a).

b. Αποσύρει τον κάθε βλαστό που δεν «εντόπισε» τροφή (b)
αφήνοντας πίσω ένα είδος λάσπης που λειτουργεί σαν
εξωτερική μνήμη η οποία υπενθυμίζει στο Physarum τα
αδιέξοδα μονοπάτια.

c. Αποφεύγοντας τα μονοπάτια αυτά, φύεται αποκλειστικά κατά
μήκος της συντομότερης διαδρομής (c) από την αρχή του
λαβυρίνθου ως την τροφή .

http://arxiv.org/pdf/1106.0423v3.pdf

https://vimeo.com/67686724

https://youtu.be/mvBSkt6LhJE

https://youtu.be/BZUQQmcR5-g

https://youtu.be/lls27hu03yw

Το σιδηροδρομικό δίκτυο του Τόκυο (χρόνος: 26ώρες)

Ο λαβύρινθος του παραδείγματος
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